*SOLVED* problems with com.nito.updatebegone

I went through the process of jailbreaking my ATV2 via seas0npass. Went well. I then proceeded to install nitoTV and XBMC via ssh. That also went well. I then plugged in the ATV2 to a TV and went through the menu system for setting up language, etc. Then I connected the network. That’s where the device began to loop on the menu. Looking at the logs, it looked like frontrow was crashing repeatedly.

I then uninstalled all the xbmc and nito packages that I could find and that got the menu system into a stable state. Then I began installing nitoTV and XBMC again. That all went well. But once I tried to install a nightly build of XBMC, I kept getting errors about com.nito.updatebegone. I have added the nito repository multiple times, done apt-get update multiple times and they all keep failing to install com.nito.updatebegone. What are my options here? Can I re-seas0npass my ATV2 to start over? Is there a command I’m missing to get this fixed? See below for the error message.

 

EDIT I had already tried a couple times to reseas0npass my ATV2 with no luck. It finally worked a little bit ago and I started from scratch. XBMC nightly is installed as well as com.nito.updatebegone.

Here is what happens when I try to install com.nito.updatebegone after an apt-get update. Does it look like I have all my repositories?

Apple-TV:~ root# apt-get update
Hit http://cydia.zodttd.com stable Release.gpg
Hit http://apt.awkwardtv.org stable Release.gpg
Hit http://apt.thebigboss.org stable Release.gpg
Hit http://apt.saurik.com ios/550.58 Release.gpg
Ign http://mirrors.xbmc.org ./ Release.gpg
Ign http://repo666.ultrasn0w.com ./ Release.gpg
Hit http://cydia.zodttd.com stable Release
Hit http://apt.awkwardtv.org stable Release
Hit http://apt.modmyi.com stable Release.gpg
Hit http://apt.thebigboss.org stable Release
Ign http://mirrors.xbmc.org ./ Release
Hit http://apt.saurik.com ios/550.58 Release
Get:1 http://apt.modmyi.com stable Release [1331B]
Ign http://repo666.ultrasn0w.com ./ Release
Hit http://cydia.zodttd.com stable/main Packages/DiffIndex
Ign http://repo666.ultrasn0w.com ./ Packages/DiffIndex
Ign http://mirrors.xbmc.org ./ Packages/DiffIndex
Hit http://apt.awkwardtv.org stable/main Packages/DiffIndex
Hit http://apt.thebigboss.org stable/main Packages/DiffIndex
Hit http://repo666.ultrasn0w.com ./ Packages
Hit http://mirrors.xbmc.org ./ Packages
Ign http://apt.saurik.com ios/550.58/main Packages/DiffIndex
Hit http://apt.modmyi.com stable/main Packages/DiffIndex
Hit http://apt.saurik.com ios/550.58/main Packages
Fetched 1331B in 11s (111B/s)
Reading package lists… Done
Apple-TV:~ root# apt-get install com.nito.updatebegone
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package com.nito.updatebegone is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package com.nito.updatebegone has no installation candidate