SOLVED: problem enabling Flash? I'm talking Adobe Flash!

I went back to my Intel Tiger Restore discs and used Pacifist, but all I found was CoreAudio.framework instead of CoreAudioKit.framework. Did you have the same problem? How did you fix it?

Please help…this is frustrating!

Thanks in advance.

medialounge

SOLVED!

Here is the answer to the problem I once had and did some research and it worked like a charm!

Here is what I did.

  1. Used MacBook Intel Tiger Restore Discs
  2. Downloaded Pacifist
  3. Launched Pacifist and inserted Intel Tiger Restore Disc 1 into iMac
  4. Clicked on button “Open Apple Install Discs” (after a long wait, it asked for disc 2 and then disc 1 again)
  5. Within Pacifist I did a search for CoreAudioKit.framework and it found the folder!
  6. I selected the CoreAudioKit.framework folder and extracted to my desktop
  7. Using Transmit (my personal favorite FTP app), I copied the CoreAudioKit.framework folder over to the Documents folder within the Apple TV directory
    ---- Then, I followed the instructions on this page http://wiki.atvflash.com/index.php?title=Enable_Flash(see steps 1-4)
    Note: Make sure you reboot the Apple TV by going to NitoTV > Settings > Reboot Apple TV

Enjoy Adobe Flash!

I can testify that it does work! And I’m running the latest atvflash software 3.6.3.

Take care

medialounge

Hi,

I have followed these steps.

I get an error message “Adobe Flash installation failed, popping controller in 5 seconds”

I noticed when I tried it a second time the CoreAudioKit.framework folder was removed from the /Documents folder on the AppleTV. I FTP’d it again and tried to install… same prob.

I noticed the log file:

2009-09-26 07:54:18.709 mHelper[210] Root filesystem already writable

2009-09-26 07:54:18.710 mHelper[210] mounting image: /Users/frontrow/Install Flash Player 10 UB.dmg
2009-09-26 07:54:20.898 mHelper[210] mounted: /Volumes/Install Flash Player 10 UB 1
2009-09-26 07:54:20.924 mHelper[210] removing file at /System/Library/Frameworks/CoreAudioKit.framework then install
2009-09-26 07:54:20.936 mHelper[210] copying: /Users/frontrow/Documents/CoreAudioKit.framework to: /System/Library/Frameworks/CoreAudioKit.framework

Any ideas?

BTW, I made the permissions on the CoreAudioKit.framework folder read-write by everybody in case it was a security issue.

regards

Adam