[solved] Firefox somehow preventing playing of files?

Ok, this is weird.

Previously everything worked fine with my Apple TV but suddenly I have problems playing video files that I downloaded via Firefox vs files I downloaded via iGetter (both on OS X).

Infuse is unable to gather metadata or play the video file when downloaded via Firefox, the “film” icon is greyed out.

The same file, downloaded via iGetter, in the same folder, just named differently (just replaced an ‘o’ with an ‘a’), works fine.

Neither reboot of the Mac or the ATV helped in any way.

The files are exactly the same according to filemerge and Mediainfo.

 

Anyone have any idea what is going on? It’s as if there is some hook on the system that prevents ATV to read aynthing from the file except the name…

 

Edit: my last sentence gave me the right idea, right away :slight_smile:

For some reason, Firefox sets file permissions to only allow the owner of a file to read and write the file (600). iGetter allows group and others to read the file (644).

Damn, why didn’t I think earlier to check those permissions :slight_smile:

bug report for that Bug #1227497 “Missing group permissions on Firefox downloads” : Bugs : firefox package : Ubuntu