[solved] About Seas0nPass-win for ATV2 and the "Unable to retrieve firmware details. Please check your internet connection."

Dear all,

I guess many of you like me faced this pop-up message when running the Seas0nPass executable file.
I’m writing this topic to save you some time and have a better understanding.
No matter what version of Seas0nPass you try to run (older versions that used to work on your computer in the past), the same error message will pop up: " Unable to retrieve firmware details. Please check your internet connection and firewall settings. ".

Lately (early Dec.2015) I faced this when I decided to prepare to JB my ATV2 (currently tethered boot JB for 5.2.1) with the new un-tethered JB for 5.3 (Seas0nPass 0.9.6).

You’d spend hours trying to disable your antivirus and firewall, kill processes and/or set security rules, reboot, try with admin rights… Yes it is sometimes needed to disable you AV and FW, but the problem may reside somewhere else.

It took me a while and some research in a lot of forums to find out that Seas0nPass needs internet access to access some resources and if I followed correctly the experts, there’s in particular one website it relies on and that website sometimes is down!! Therefore in this case it’s pointless trying to find a fix on the client side :-(.

Well, this being said, I have no idea why it is down (maintenance?) and when it will be up again.
I won’t complain or nag about it because the Firecore Team did (and still does) an excellent job to help the community hence it is about being patient a few days until it is fixed.
Cheers,

Edit: (find below the solution I’ve found for my case)
ST

Thanks ST. You have saved my sanity. I have tried everything including replacing the cable, checking the hostfile, disabling the FW, installing it on different machines (Apple and PC). Yes, it is not a client issue. I am going to join you and patiently wait that the server side will be fixed.
Cheers
A.

Thanks ST. You have saved my sanity. I have tried everything including replacing the cable, checking the hostfile, disabling the FW, installing it on different machines (Apple and PC). Yes, it is not a client issue. I am going to join you and patiently wait that the server side will be fixed.
Cheers
A.

@ams67: if you have a Mac the latest v0.9.7 should work. A friend of mine just tried today and it doesn’t have the error message.
Therefore it seems that the v0.9.6 build for Windows doesn’t have an updated access to the server while the new version 0.9.7 (only for iOS now) has this access properly set up.

@shitobj - I did try on Mac with v 0.9.7. This time when i click on “Create IPSW” I get the following error: No Device Detected. Please connect the Apple TV via USB to continue.
I tried with two different cables and also 2 different ATVs. No luck. I wonder if there is an alternative to FireCore as this is obviously not working for some reason…

some problem here. I checked the Seas0nPass.log and saw this:
A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 93.174.90.30:80
Unable to connect to the remote server

seeing some abuse about 93.174.90.30, so that might be the reason it’s “gone”

IP Address 93.174.90.30 is listed in the CBL. It shows signs of being infected with a spam sending trojan, malicious link or some other form of botnet.
It was last detected at 2015-12-09 01:00 GMT (+/- 30 minutes), approximately 22 hours ago.

From my side, still no improvement with the Windows version. Still showing the pop up message.
However in the Seas0nPass.log they show different exceptions details, while indeed both are linked to server access:
1/ SeasonPass v0.9.6 for iOS 5.3
Log says it’s Version:0.9.5.15391
Exception classes: System.Net.WebException
Exception messages: The remote name could not be resolved: ‘files.firecore.com

2/ older SeasonPass I used in the past for 2 years for my iOS 5.2.1 tethered boot
Log says it’s Version 0.9.0.11903
Exception classes: System.Net.WebException
Exception messages: The remote server returned an error: (403) Forbidden.

[SOLVED] I’ve finally found out what was wrong. It was the Seas0nPass executable file for Windows.
Firecore tells us to use the latest version 0.9.6.18647 of Seas0nPass. OK! So v0.9.6 it is.
However what is available in the download page for 0.9.6 links to a file that is not the correct build. It seems there are 2 versions of 0.9.6 out there (from github, seas0npass.org, etc…).
<< The good version that works is the one with MD5 check-sum = 409a84cea921ee0979fa7ef60b36857c >>
The bad version has an MD5 check-sum = 6106a6d604926a67e60162dc27a908da

So actually when you get the pop up message “SeasOnPass is unable to retrieve firmware details” and you have correctly disable your AV and verified your FW, it is not necessarily a server access issue or some signing problem. It can simply be that the .exe you use is the wrong one.
Hope it helped :wink:

Hi there,
Can you please post the right version for me. I am using a Windows PC. Thank you very much. You can also e-mail it to ruparee9@gmail.com Much appreciated… brgds, Marc

UNSOLVED, you are talkin about 2 different errors. even if u have got the one version that doesnt pop up that firmware error, it still does pop up with that cydia connection error!

Hi,
I don’t remember which download site provides the right file, not easy for me to check as it takes ages from the place I live in. But you can get mine here: https://www.sendspace.com/file/7rmxgq (Seas0nPass-win v0.9.6.18647 for ATV2 iOS 5.3 - OK.exe )

It solved that problem described in the Title (different error message from yours) and my thread is closed.

For Cydia connection issue (when is another problem that arrives later in the process), it’s in another thread: http://firecore.com/forum/topic/13513 “Cant connect to cydia server” and yes this one is still unsolved because the ih8sn0w.com server is down.

Hi,
I don’t remember which download site provides the right file, not easy for me to check as it takes ages from the place I live in. But you can get mine here: https://www.sendspace.com/file/7rmxgq (Seas0nPass-win v0.9.6.18647 for ATV2 iOS 5.3 - OK.exe )[/quote]

You sir have made my day! I tried to install the firmware so many times, using 3 different cables, with the power cable, without the power cable, nothing worked. This exe worked like a charm. Thank you!