Solution for NitoTV to access a Windows Server Domain Share

Hi all,

I’m posting this because this one took a bit to sort out, and neither this forum or FireCore support had an answer for this. This is a bit of an old one when it comes to getting Linux and old NT4 to talk to server 2003 and 2008. But I never found any reference, I just happened to be at an electronics mfgr’s office trying to network a Windows 7 laptop to an OLD Assemblion circuit board assembly machine that runs Windows NT 4 . This same solution I found worked, and worked well with Nito. Boxee and XMBC networked up without issue, but I fought nitoTV for a couple weeks. Here is the solution.

Get on your Windows Server/domain controller console and launch Domain controller security settings (Start -> Programs -> Administrative Tools -> Domain Controller Security Settings)
It is not Domain security settings, there are 2 different management consoles, for those not as familiar with Windows Server.
** also as a note, you can do this on a windows xp, vista, 7 box as well: Just click start -> run, then type in “secpol.msc” and continue with the directions.

Open Security Settings -> Local Policies -> Security Options
There will be 2 things to change here:

Microsoft network server: Digitally sign communications (always) |Change to “Disabled”.
Network security: LAN Manager authentication level |Change to “Send LM & NTLM - use NTLMv2 session security if negotiated”
Exit and then click start - run, enter “gpudate” in the run box (or at CMD prompt) to force the immediate update of the policy changes. otherwise it is a 15min interval for that to update.

Please note, this does weaken some of the domain security. Please be aware of the implications and do at your own risk. This server is my home server with mostly personal media, etc. Not that worried and behind a sonicwall 3060… Any how I hope this helps anyone in this situation.

Cheers,

Rob

[attachment=0]Domain settings.jpg[/attachment]

THANK YOU SO MAUCH!!!

I had to change these settings at the following locations in 2008 Rc2:

  1. Open Start>Administrative Tools>Group Policy Management
  2. Drill down to domains>Domain name>Domain Controllers
  3. Right click on Default Domain Controllers and choose Edit
  4. Drill down Computer Configurations>Policies>Windows Settings>Security Settings >Local Policies>Security Options