So Many Delays Infuse Is Becoming Unusable

It’s not extra for the mobile apps. If you paid for the pro you can restore it in the app.

Thanks for the info and the video.

This slowness definitely isn’t typical, and we’re looking into what may be going on here.

For fun, you may try installing today’s tvOS 14.4 update to see if there is any change.

  1. I’ll be installing the tvOS (and iOS) updates tonight sometime.
  2. While I wasn’t trained as a developer in college, I ran my own business for close to a decade (before it was doing well enough I could retire early from that). I did all the coding myself, in Perl, Java, TCL, bash, MySQL, Javascript, and others. More recently I’ve been using Python and also use SQLite. I’m not asking for a job or anything, but just want to say that I have debugging experience so, since this is a unique issue, let me know what you need and I’ll be glad to help in any way I can, even with a raw gamma version or something.
  3. Could the size of my library be part of the issue? I didn’t think much about that until today.

A lot of interesting posts - let me catch up.

I have one 4K ATV. I bought all 4 of mine within a couple weeks of each other. The 4K is on a projection system in the barn with a 135" screen. The others are all just HD. The one in my study, with the longest delays, is in my study. It’s also the most used - by a WIDE margin. I can check version numbers in settings if that helps. With all I have going on right now, I haven’t had time to walk down to the barn and check things out. I have them connected through CAT5e or CAT6 (depending on the building, house or barn).

I’m not clear about the app refresh. Do you mean just the app, or refreshing metadata? Could you give me more detail on that?

I did get the Recently Added section FINALLY removed. So happy about that!

By the way, do we have private messaging on these boards? If you are stuck with conventional satellite and looking for better, PM me, since I’ve found a solution that works now and one that will be better that should be available in 2021.

Gladly, in the ATV settings it’s Settings > General > Scroll down to “Background App Refresh” click on it, make sure that the first item, “Background App Refresh” is ON, then below that where there should be a list of apps that can take advantage of this. Infuse should be one of them. Make sure Infuse is “On” and then the rest are “Off”.

As to private messages, yes you can click on your user pic at the top right of the page and then on the envelope icon in the menu it opens.

I finally got DSL for internet and for me it’s enough, don’t do a lot of 4K streaming and the majority is web so for now I’m good. Just waiting to see what the offers are with the low altitude sats and the 5G hot spots when they become available.

Like James said, what you are seeing is REALLY unusual. I’ve never seen that type of delay ever with infuse. One other thought, how many apps are you running on your ATVs and any like the channels app that may be taking a ton of space? It really looks like Infuse is having to dig for the basics which is not normal. Is it possible you have a switch or router going south or perhaps one Ethernet cable or more that are becoming flaky? Just brainstorming a bit. One more question, what protocol are you connecting to your server with? SMB, FTP DLNA, etc?

Oh, boy. Alarm bell just went off.

I am using Channels. And, come to think of it, this problem is more recent. But I don’t have a normal Channels setup.

I have the Channels DVR running on my media server. I was normally running the test version of Channels through TestFlight. Our ISP is pretty good - they resell cell data in the area, so if you can get a good cell signal, you can get a pretty decent internet connection. (I’m still planning on transferring once SpaceX gets Starlink online, though!) But there was an issue with AT&T (read: incompetence) and a lot of SIM cards were made obsolete one Monday morning, so I had no internet for over a week, while my ISP was rushing to get new cell modems to a number of us subscribers.

I used tethering and could do some activities and get some internet use in that time. I got on the Channels forum and asked if there was a way to use Channels in that time, without the program guide coming through the internet. There were a few other issues, so one of them PM’ed me with a code so I could use the stand-alone Channels program on ATV. It’s a $25 program. It doesn’t connect to my home DVR.

So I have the TestFlight version of Channels AND the more expensive one, too. (And, now that I’m checking, the normal version, too.) Just now I deleted all but the TestFlight version. After that, I force-quit Infuse and Channels, then went to Infuse and things could have been faster, but they went much faster than they have before. From the main screen, I went to Library and went down 3 directory levels in about 30 seconds or less. So I’m beginning to think the issue might not be Infuse as much as it it Channels.

I would think, since a lot of the work for this version of Channels should be done on the DVR backend (on my media server), what does Channels use memory for that it needs so much on the ATV?

Also, one other thought: I’m big on organizing my folders so it’s easy to find what you want if you think logically. At the top level, I have Audio, Storage, Media-Other, and Video. Then, under Video, I have 6 subfolders and under each of those, more subfolders. To make it easy for guests staying in our barn to navigate their way through, I had saved my media server share several times. I had the top directory saved as “Local Library,” then the video folder saved as “Video Library,” the audio one saved as “Audio Library.” You get the idea - that way people could quickly find the kind of file they wanted.

I’ve wondered if part of the issue could be that when it goes to one of those shares, it might be slowed down by having to read folders for all shares using that volume.

It may help to cut back the redundancy. I have my NAS as the main share, from that I have 3 favorites

The first is “TV Shows”
The next is “Movies”
The last is “Test”

Inside the TV shows are folders 1 thru F, G thru M, N thru S, and T thru Z
I then sort all the tv shows into those with this file/folder structure.

I then have the Movies divided into about 8 sub folders grouped by first letter like the TV shows.

This has been working great for me and it also makes finding things easy.

I usually use the library for most of my viewing but occasionally I use the favorites.

Okay, redundancy resolved - using only one share. I figure people can go to Local Library and anyone we’ll be inviting should be smart enough to see, in that folder, what what the categories are.

I can experiment more tomorrow. I want to run the version of Channels left on my ATV for a bit, poke around, then go to Infuse and see if things are okay.

Any idea what Channels does that it could be using so much freaking memory or resources on ATV?

If I remember correctly it hogs a bunch for the channel guide and info on recordings.

I don’t use it but there are multiple posts on the forum where it was causing the Infuse metadata to be cleared quite often.


Okay, that makes sense. That was about all I could think of that Channels would need: Guide data and metadata related to that. I think I remember, when I had no internet connection, getting the data guide from the Channels server (the DVR) and that the timing was wrong on the ATV - it lost the time when the internet went out. (Why? Who knows!) So I’m betting the thin client version of Channels just gets the data from the DVR and the stand alone version of Channels stores all that on the ATV.

Here’s an interesting development.

Remember, I had 3 different instances of Channels, one that was a thin client, connecting to the backend DVR server, the other was a beta test version of that same one, and the last was the big version. I removed two and left the beta test. (It has features I really like.) Once I did that, force-quit that version and force-quit Infuse, things came up quickly.

This morning I got up and, while having breakfast, used Channels to watch a show. Then left it and went to Infuse and things took longer to load. Not absurdly long, but longer than before. A few minutes ago I went into ATV settings to turn off background refresh. I found that the only apps listed were Infuse, Netflix, and Podcasts. Well, just to be sure, I turned it off for the other two, so I could see what’s going on.

So if Channels is an issue, it’s due to memory usage - but, from all I can tell, I’m pretty sure the version of Channels I use is a thin client, letting the DVR server do much of the work.

We’ve added a few changes in today’s beta update which are aimed at addressing cases like this.

If you’d like to give this build a try (via TestFlight) to see if it improves things for you please drop me a PM.

We’ve added a few improvements in today’s 6.6 update which are aimed at resolving some reports of app slowness.

If you’ve been seeing issues, please try this new update and let us know how it goes. :slight_smile:

1 Like

Just updated an ATV4K and it’s pretty fast now on loading favorites for me. It was fast enough that when I loaded movies I got to see the poster for “Wolverine” change 3 times in a couple of seconds. LOL

Thanks James, and I hope @Tango has as good of luck!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.