So Many Delays Infuse Is Becoming Unusable

I’m using Infuse Pro 6.5.8 (3407) on Apple TV. I wrote in with this problem and, at the time, had not checked my version. The suggestion was to update to Infuse Pro 6.5. I’m having severe delays and freezing issues. (Also, possibly related, is that Infuse loses its place on a Samba Share - wondering if it’s all tied into caching or something similar.)

My media server runs on Debian Linux and I access it as a Samba share (although I do have MiniDLA running on it, but never seem to access it that way). I’m only playing video through Infuse. I am using local metadata. (I’m in a rural area, so I don’t have normal internet and am trying to reduce my bandwidth usage in whatever ways I can.) My share has a structure like this:

/Library/
±–>(lots of other folders)
±–>/Video/
±----->(some other subfolders)
±----->/TVShows/
±-------->/Comedy/
±----------->(lots of folders with an entire series of episodes in each folder)
±-------->/Drama/
±----------->(lots of folders with an entire series of episodes in each folder)
±-------->SF&F/
±----------->(lots of folders with an entire series of episodes in each folder)

So, mainly, I’m using /Library/Video/TVShows for everything at this point. I do have several terabytes of files, plus, under /Library/Audio, a lot of old time radio shows and music files in ALAC.

For a long time I didn’t have any issues at all, but now I’m dealing with two kinds of delays that are getting longer and longer, to the point where Infuse is almost unusable.

The first type of delay that showed up was just freezing during movement and selection of folders and files. For instance, I’d go into Comedies and I have at least a couple dozen folders in there. I’ll use my Apple remote and start moving down the list of episodes and Infuse will just stop and freeze. These delays are the shorter kind, but can last up to 10 seconds and, in going through a list of a couple dozen folders, it can do this several times.

The second type of delay gets longer and longer and I’m wondering if there’s a caching issue or if I have too many shows with metadata on my drive. I’ll go to a folder and click on it. Sometimes this is only a folder with subfolders, sometimes it’s a folder with video files. I have had times where I can click on a folder, get the rotating grey circle/wheel going around. This delay has gotten so long that once I see it, I shift to something else while waiting. I can click on a folder, then open a desk drawer, pull out a bag of pistachios, reach over and get two bowls, put them near me, and pour nuts into one and start eating them, all while waiting on Infuse.

I can press “Play” on a folder and it can delay various lengths of times before I get a menu. I can go into a folder to try to find a particular episode of a show and, with fewer than 50 episodes, it can still take a long time with the spinning circle, before I can do anything else.

Right now I have been rewatching Space: 1999. That’s 48 episodes, so it’s not like I’m trying to load every episode of The Simpsons. Due to Infuse’s issue of losing its place in the Samba share directory structure, I may go to Infuse and find it’s in /Library/Video. I navigate down, within that folder to TVShows and click on it and wait. Then my 3 folders (Comedy, Drama, SF&F) load. Then I click on SF&F and wait. And wait. And wait. Then the folders come up. I start navigating down the list and have to deal with 2-3 freeze-ups for anywhere from 3-6 seconds before I get down to the Space1999 folder. Then I click on it and wait. Sometimes I wait there as long as I wait for the SF&F folder to load. (Note above - while I haven’t timed it, I can do a fair amount while waiting for that folder to load.) Now I’m FINALLY looking at the episode list for this show. I’m in the 2nd season, so as I navigate down through about 30 episodes to get to my current one, I have to deal with Infuse freezing up 2-3 times as I navigate down the list. I FINALLY get to the episode and can watch it. If I start counting seconds (1001, 1002…), I can get to 30 from my first click until I can watch the show.

There is one other issue and I can put that in another topic, but since I wonder if this is related to caching, I think it could be related.

Infuse loses its place a lot. I can be in /Library/Videos/TVShows/Comedies/TheRedGreenShow and I stop watching videos with Menu. Then I click the Home button and go to Apple TV’s main page. A few hours later I come back and I enter Infuse and get “An Error Occurred.” I hit Menu and have to go up to Comedies again. When I first got Infuse, it would stay in the directory, with the selected episode still selected, but lately it almost always loses its place. Sometimes I get “popped up” 2 directory levels before I can re-navigate to where I was when I last used Infuse.

The last issue is something I can deal with, but these delays make me feel like I’m back in the 1980s or 1990s and dealing with older computers that have to take a lot of time to process some things. It’s frustrating how long it can take to navigate through folders and get to a specific video to watch.

I like Infuse’s interface, the ability to easily pick Shuffle and a few other features, and the use of metadata so I can see things like episode descriptions and summaries, and tracking what I have and have not watched, but this is so frustrating that there are many times I find myself using other viewers instead, since I can get in and start watching a video in a few seconds with mouse clicks and no prolonged waiting.

Rather than leave this up in the air, I’d like to point out something to the credit of Firecore.

That 3rd issue I mentioned, about Infuse losing its place, is one I had reported. (That’s when I was told to upgrade - I don’t know what version I was using at that time.)

I posted this in the morning and didn’t get back to the computer until something like after 9 PM that evening. There was a response to that older email discussion from Firecore asking for diagnostic information.

So they saw this, tracked down the earlier issue, and responded to me directly in email.

Kudos, Firecore!

Thank you!

1 Like

I got the same problem. I have a Synology NAS and an Apple TV 4K, both connected via Gigabit to my Router. Never had any problems but sinces some weeks (or month) Infuse often freezes when I go to all Episodes of season for example.

I also got a lot of freezes when I mark an episode as watched/unwatched.

Does infuse use sqlite under the hood?
After a while, an sqlite database can get quite slow if you don’t vacuum it periodically (unless autovacuum is enabled, of course).
(A PRAGMA optimize; might help too!)

EDIT: Plex has an “optimize database” step for this reason too, I believe. If infuse does use sqlite, it might make sense for the devs to add a button for that too.

1 Like

I sent in a diagnostics report, as asked to do in direct communication with them, but that was 10 days ago. I know they have a lot of bugs to deal with, but this is getting bad. The delays get worse and worse. Often the delays happen at points where I wouldn’t think Infuse would be using the DB, such s going from one folder to a subfolder that has only subfolders (and not video files) in it. Unless Infuse is going more than 1 level deep in looking for videos, that shouldn’t slow it down.

So the delays have gotten worse and it turns out it’s happening on multiple machines. I’ve been having issues on my Apple TV in my study, but the delays are happening on the great room Apple TV as well. When my wife and I wanted to binge watch Warehouse 13, it took long enough to step through the folders and get to the next episode of Warehouse 13, my wife was asking what was wrong and could we use another program or something, or just get the DVDs.

I told her I didn’t know which episode we watched last without going through Infusion.

It’s gotten so bad I’m now using VLC, which I’d prefer no to use for several reasons (including no metadata on VLC and no tracking of what has been watched).

I can get that this might be a DB issue, that would make sense, but I can’t see why the program would need DB access going from folder to folder and not going into folders with video files that are linked to metadata.

I wouldn’t be as disappointed if this were a free or $1.99 program, but Infuse is expensive enough it really should work and not lock up continually during navigation so that the UI is a frustrating experience.

Can I ask what tvOS your running?

I have it set to auto-update. It’s using tVOS 14.3 (18K561). I checked for other updates and there are non.

The reason I ask is that I had been holding off of the 14.3 update due to other issues they were having in other areas but I had that hated “do you want to update? Now, Automatically, or later” warning and I clicked the wrong one and got updated to 14.3 against my choices.

Within a day or so I started seeing slow downs in infuse between screens and getting the spinning circle between folders. It kept getting longer and longer finally taking over a minute to open a favorite. I thought it was something with the NAS or other servers that was slowing things down but could find no reasons.

I did a force quit of Infuse and presto, everything was back to super snappy again. I notice things “appear” to be getting slower again (hard to tell since it’s such a gradual change) but when I thought it may be slower I again force quit Infuse and things again appear to be back to snappy.

Now the important part, I have 4 ATVs and only the one on 14.3 is experiencing this, the other three are all snappy with all 4 being on 6.5.8.

I’m thinking that maybe tvOS 14.3 introduced a memory leak of some kind that over time slows down Infuse.

Strictly a non programmers view.

I hope that @james can get some nugget of insight from this to help.

If you can submit a report from your Apple TV (Infuse > Settings > Submit Diagnostics) the next time you see this issue we can look further into what may be going on here.

You may also try browsing using the Library, as this may work a bit better if you have a lot of folders…especially TV show folders.

There’s a bit of history behind that, including 2 tech support total blow-offs.

Short version: Did that on 1/5 and the code is BART5. (Just did it again with code RDM99.) I sent the code in and it has been ignored for the past 12 days. More on this below. I’m including a history of this one issue thread and I think that it’s important. While I’ve usually gotten support responses within 48 hours, this thread has two points where I responded and was ignored with no response at all. Not even someone saying, “Okay, we’ll look into it.” Just got totally ignored and blown off.


Long version, including the blow-offs and thread info.

I reported one of these issues in September (the one about Infuse losing its place in the directories). It’s issue #131404. The reply was to upgrade to 6.5. At the time I had a lot going on, so it took me a while to check on the version and do an update. Then I was a bad boy and tried threadus ressurectus on December 19th. (After all, the “close out” email does say to respond to the same thread if there are more issues.) I pointed out that when I checked, it was Infuse Pro 6 and, according to the App Store, it was the latest version.

At that point, I also mentioned the UI freezing in the same response email.

No response at all.

So I posted this thread on January 5, 2021. To Firecore’s credit, I got a quick response on the issue email thread, asking the same thing you just asked.

So I did it - I sent in diagnostic data and, on that email thread, I stated the code it gave me was BART5. That was on January 5th.

No response. On the 10th, I responded and said, “I haven’t heard anything, is this issue still live?” and I never heard back.

1 Like

@NC_Bullseye: Thanks. I tried force quitting and still had the same issue. I don’t know if this board can take video uploads, but I’ve considered just taking a video with my iPhone to show how frustrating it is to try to navigate with Infuse these days. I can be almost at the video file or folder I want to watch and it’s still faster to quit and navigate to the same file or video with VLC.

Thanks @Tango

We’re going to be looking into this.

@james : Thank you. What bothers me is that twice, in that email thread, things just stopped dead and there were no responses.

I’m trying to upload a video to show just how bad this has gotten. I force quit Infusion, then started the video. At :06 in (that’s six seconds), I clicked on Infuse. To make it short, I spent VERY little time between when a new screen cam up and when I picked an action on that screen (like selecting a subfolder to go into). The video was over 5:20 long. Over 4:00 of that was me trying to navigate from the main Infuse screen to the file I wanted to watch. (I took 30-45 seconds at the end to point out another issue I always have with Infuse.)

I think this is important because it shows I’m not exaggerating when I say Infuse is glacial on my system, but I’m also hoping that watching this video would help with some of the troubleshooting.

I couldn’t upload the file - I kept getting an error message, but it never gave me useful information (like if my upload speed is too slow or if the file is too big).

I was finally able to upload it to Dropbox and link to it there.

I really would like someone from Firecore to look at this. I know it’s over 5 minutes, but I think it’s important for someone from Firecore to see just how unuseable Infuse has become at this point.

Have you tried a speed test in infuse?
Does this happen on an iPhone/iPad or only atv?

You can remove all of those list showing up on the home page. Not sure that it will do anything but here you go:

Where is the speed test?

At this point I have only been using Infuse on tvOS, not on my mobile devices. I have to check - if I don’t have to pay to get it on my iPhone or iPad, I’ll try it out, but, at this point, I’m not spending more on this.

As to the recently added movies, got it - finally! (I had asked about it before, somewhere, and the response wasn’t useful.) So nice to have that feature gone!

Something that, literally, just occurred to me is that it may have something to do with the common source. (@james, this should interest you!) This happens most on my Study ATV, but is happening on our Living Room ATV. The problem gets worse over time. The Study ATV, which is used much more, is at the point it can take 3-4 minutes to navigate to what I want to watch. The Living Room ATV is not nearly that bad.

So what just hit me is, “What do these two have in common?” The answer is that they’re playing from the same media server. The video on that server (that I’m using) is on a 10TB drive that has only about 2TB of space left. It’s all filled with TV shows. I put all the seasons for one show in a separate folder.

I think the important points are:

  1. It gets worse and worse over time on each separate ATV
  2. At least 2 out of 4 ATVs are having this trouble. (I haven’t had time to go to the guest house and check the other 2 ATVs.)
  3. The major thing they have in common is they are accessing a rather large library of episodic TV shows.

Putting that together, I’m wondering if the issue is the large number of files it’s accessing and since it gets worse, that makes me STRONGLY suspect there is a problem with the internal DB and that it has a caching problem and is storing more and more useless information. I have limited internet bandwidth (we live in the boonies), so I don’t want to have to keep downloading metadata, but I’m thinking it’s choking on metadata and that it’s either caching stuff that’s already there or some similar issue. Also, notice this happens, with super long delays, on discovering what shares in the favorites list are on the network and in reading the folders, even when any video files are several levels deeper in in the directory structure.

I don’t want to derail what you have going but the speed test on the ATV is Settings > Shares > Click on the saved share > near the bottom, is Speed Test > Navigate to a video and run it.

I too am in the outer ranges of the boonies and I can relate. One thing that has helped me a bunch is the background app refresh. Infuse will go out when Apple lets it while the ATV is idle and do fetching and syncing. One thing that really made this work for me is going to the ATV settings for background app refresh and turning off all the other apps and letting Infuse be the only one allowed to do it. It’s helped me on the long fetching and syncing cycles.

Watching your video and I apologize if you’ve answered these questions before. Are these ATV gen 4 or the gen 5 4K? How are you connected to the atvs and the server? Ethernet or WiFi?.

As to the numerous recently added movies with the same poster if you long press on one of the duplicates it will give you a menu with Edit Metadata as one option, Select that and you will then be able to see what file Infuse is interpreting as that movie. If you post that file name we can figure out why Infuse is getting the wrong metadata for it. You don’t have to do any searches there just click the Menu button a few times to get back to your home screen.