Just got my Apple TV 4K a few days ago and have installed infuse on it. I’m using it to play a mixture of 1080P and 4k 265 files which are stored in a share on my Netgear ReadyNAS RN314. I’m sure read performance varies between various manufacturers of NAS for a given protocol but as the subject line suggests I’m wanting to know what connection method I should use to my NAS share for the best performance. Playing a 30GB MKV 4K 265 (23.976FPS) file last night I had way too many video “blips” where the video would freeze momentarily and the audio would continue normally.

My ATV 4K is connected via gigabit wired connection to the Netgear ReadyNAS. Any help appreciated

Welcome to the forum!

First thing that would help is what protocol were you using when you were experiencing “blips”?

One thing I’d suggest first is to try a new Ethernet cable of at least cat5e specs. Weak cables can be a real nightmare to find when they don’t outright fail.

I’d added the server as NFS. I’ve changed this to SMB and left at auto for now. I’ve just got the ATV 4K as I was previously using a Dune box but wanted to play 4K files.

All my cables are CAT5E and of good quality. The NAS connects to a gigabit switch on the first floor, the ATV connects to a gigabit switch on the ground floor and both switches connect to Netgear Nighthawk R7000 router. My ReadyNAS has two Ethernet ports. I could configure the second and direct link this to the ATV but would need to check that the ATV would then still bridge through the NAS to the internet.

I’ve gone through a few different configs and here is what I’ve found:

NFS and FTP were about even on performance with SMB being the slowest. Plex (if available) was the fastest option over the other ones. However plex doesn’t really handle ISOs so I end up doing a hybrid of Plex for MKVs and the occasional iso is served out of a deferent share/folder using NFS.

Just to try a few remedies that have worked for others, you may want to try switching to SMB 2 since 3 apparently adds a layer of security that adds overhead and has caused some users problems with high rate files. Second, try the Legacy setting, some people report having solved their issues using this implementation of SMB.

As to the cable, I was referring to trying a new cable because cables don’t just quit working when they fail, they can cause deteriorated speeds and still pass data. I had a brand new “name brand” cat 5e cable between the ATV and router that would not work for 4k video but fine for 1080 and lower. Changed the cable and all was right with the world, both 4k and lower rates worked great.

I’ll maybe test play the same file again and switch the SMB type if the problems persist to see if this is the cause. Of course it could simply be corruption in the file when I’ve moved it between my Mac hard disk and NAS. I’ll try a few different large files in case I’ve just been unlucky.

Appreciate what you say about the cable. I installed CAT5E throughout my house years ago when I first moved in so it’s only the last link that is “patched” with pre made cables. I was saying that I could simply direct link the ATV and the NAS’s spare ethernet adaptor so that there was no switching in between the two and no other network traffic on that cable. Probably a bit OTT though!

I am using Asus router with External HDD. First time I tried SMB protocoll but until 25-30gb MKV worked fine but largest files sometimes did not start. So I can play 4K movie, but not all, just the smallers. And I tried FTP connecting and playing everythings without any problem. Faster starting. The largest file at this time what I can playedwith infuse app 95GB 4K HDR Mission in Possible movie and ther is no lagg nothing or any problem. Try it.

I use SMB in my config 90GB blu ray copy I can play without any problems, shield TV with Kodi also use SMB evething is really fast.

My system is maybe different like yours. Router+ExtHDD USB 3.0 and Lan cable to ATV 4K.

Yes diffrent I use my sat tuner (VU ultimo 4k) as NAS, and I prefer ftp protocol to copy my rips to NAS than I have better speed write ~90MB/s read 65MB/s.

I play 4K remux and encodes off my FreeNAS setup via NFS shares without an issue. NFS has the least amount of overhead, so i’d be using that.

Both my NAS and Apple TV 4K are connected via CAT5e to a Nighthawk R7000. Have you modified settings on the router, or is it configured pretty standard?

It turns out my issue was in the file itself ? I copied it to another device and had similar issues in the same portions of video, while playing back directly using VLC. By this point I’d changed my setup to use SMB version 2 as someone had advised. I’ve had no further issues since then, but will keep an eye on it and if it should re occur, I’ll try NFS again if that is likely to be the fastest of the protocols. Thanks for everyones help and suggestions ?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.