SMB speed issue on infuse pro

Just got some speed problem with infuse on my APTV 4k 3rd gen,

I have set a SMB server on win10 and the infuse test speed is 160Mbps, and I have tried different buffer setting auto, legacy and memory , smb1 2 3

I have tried a webdav on my MacBook Pro the speed is 370Mbps,

I have tried copy a movie from win10 smb server to MacBook Pro the speed is near 1Gbps

and it shows the win10 smb service is no problem,
all the devices are connected a router.

So what’s the problem with it ?

speed from webdav

speed shows copy video from smb server to MacBook Pro

Just have tried on my iPhone same speed.

In general, SMB will perform better when using a wired connection on both ends. Wi-Fi can be used, but it may have an impact on the maximum speeds you are able to see. This is due to the nature of SMB, and not something specific in Infuse.

Infuse supports a number of different connection types, so if you device supports other methods, such as NFS, FTP, WebDAV, etc… you can try using those to see if you are able to get betters speeds.

just have tried webdav the speed is super fast than others.


but I found a problem if I use webdav, in advanced setting the path can’t be a virtual path which I have configured in webdav server, I can use the browser to open the virtual path but can’t be used in infuse advanced settings.