SMB SLOW, UPNP shows nothing in library

I installed infuse pro 5 on my apple tv 4k, and it worked fine, the library could fetch data for the movies and tv shows streaming from the hard drive plugged in the Asus AC1900p, but it streams super slow, and it always takes tens of seconds to buffer only for 1080p movies, I don’t think it’s normal, cuz it has worked pretty smoothly on Kodi which was installed my TV, they are both using SMB.

After then, I tried UPNP, it streamed much faster, it seldom buffers during watching a movie, however, it has its own disadvantage, which is there is nothing appears in the library.

As we all know, keep the video resources organizational is one of the greatest benefits we have on infuse, I can’t simply ignore it.

So I hope someone can help me with this.

Thanks a lot.

Welcome to the forum!

If you are having trouble using SMB you may try adjusting the SMB version to see if one of the other options works better with your Asus. A bit more info on doing this can be found here.