SMB shares don't work with Infuse anymore

Since updating to 2.3 infuse just doesn’t see any of my SMB shares. xbmc sees them fine so It is not permissions. Any ideas…


I have same problem

I tried updating Appletv that did not help. 


I am on 5.2 and atv 2.3 


I shared some stuff on my macbook and it sees that fine. So it is something with the SMB shares. 



I am running aTV Flash 2.3 on Apple TV 5.2.  Infuse cannot see or connect to any SMB shares, but has no problem connecting to AFP shares.

I am having the same issue. I would use AFP, but it does not support symlinks. Is there an ETA on having this bug fixed?

I have exactly the same combination of software and am using inFuse with SMB shares all the time.   I think there must be some other factor at play and it is going to be necessary to pin down what that is. I am using SMB shares where the media is hosted on an unRAID based server - what is your server end?

Another thought - what are you running on the macBook?   If for instance you have upgraded to OSX Mavericks (OSX 10.9) then that might well cause a problem as Apple changed their support for SMB. 

my issue went away after a infuse media player update. My systems have not changed but work now. I have my shares on a win7 machine that i use as a media server. It hosts all the media up to the devices in the house. 

Mine works fine since that update. But again my RaspBerryPI running XBMC never had an issue and the appletv running xbmc never had an issue with any of the shares. 


Found this and it works:
Clients logging into File Services over SMB with OS X 10.9 experience hanging connection upon login attempt.
Root Cause:
OS X 10.9 now utilizes a new SMB2 stack written by Apple.   Apple's SMB2 implementation is not compatible with many other SMB2 NAS products on the market today while Windows 7, 8, and 8.1 works just fine.   In short, its an Apple bug.
Workaround Option 1: To force your connection to be SMB1, simply type cifs://servername instead of smb://servername when connecting to a Windows or NAS share.  This is by far easier and requires no real configuration changes. Workaround Option 2:
To force all connections to be SMB1:
  1. Open A terminal window
  2. paste in the following line followed by the return key(should be all on one line):  

echo “[default]” >> ~/Library/Preferences/nsmb.conf; echo “smb_neg=smb1_only” >> ~/Library/Preferences/nsmb.conf

What the command does:
  1. Creates a file called nsmb.conf  in your  home directory at the path ~/Library/Preferences/nsmb.conf.
  2. Adds directives to force SMB connections to use the SMB1 protocol.  This is slower but stable.
How to remove the workaround:
  1. Open a terminal window
  2. paste in the following at the prompt and then hit the return button:
rm ~/Library/Preferences/nsmb.conf

Thanks alot this worked perfect for me