smb shared folder on Macs problem

Having problem with smb shared folder on Macs.
I can see Macs on network but when I connect to Macs, I can not see folders(I see loading icon)

All of these combination does not work.
iOS10/iOS11 to Sierra/HighSierra

I have no problem on VLC for iOS.
(VLC does not have smb download option, so want to use Infuse)

And is there option to disable packet signature and smb1 like Mac?

I think I can connect to smb shared folder when setting smb server to smb1 only using ProtocolVersionMap.
but it’s EXTREMELY SLOW almost unusable

You might try updating to macOS 10.13.1 as we believe this resolves at lease a few SMB issues people have been seeing.

Also, Infuse currently supports SMB1 and SMB2, so SMB3 packet signing should not be a factor here.

Yeah, smb 1/2 may not be problem after all. it’s all same - extremely slow to connect.
What about Sierra machine that I can not upgrade right now?

VLC does not have a problem at all FYI

I’ve been having this problem for months. I’ve been trying between iPhone, iPad, and Apple TV, iOS 10 and 11, and three different macs on Sierra and now high Sierra. It worked before upgrading the macs to Sierra. Ive tried after updating to 10.13.1. I’ve purchased several versions of Infuse as well.

There are a few things to check.

  1. SMB is enabled on your Mac (more info here https://support.apple.com/en-us/HT204445).
  2. At least one user is selected under ‘Windows File Sharing’ (as shown under ‘Advanced Options’ in the link above).
  3. Selected username and password are being entered in Infuse.

Note: iCloud username/password cannot be used. If you’re using an iCloud ID to log in to your Mac, you will need to set up a new ‘Sharing Only’ user as described here: https://support.apple.com/kb/PH18695

I noticed that Infuse does not connect to Windows or Linux NAS either now(or extremely slow)
It used to be ok and vlc is still fine with any machine.
Infuse definitely has a bug with smb.

It’s still the same on Infuse 5.6

After updating my server to High Sierra, I had no chance to get connected in SMB with InFuse.
But I noticed after dozen of tests that setting the “Workgroup” (in the InFuse share) helped me to get SMB working.
It’s not 100% working for each attempt, but by trying multiple times, it most surely ends up working while without the workgroup set, it will —always— fail.

Setting workgroup does not work for me.
Even auto discovery no longer works on v5.6. gotten worse.

FWIW, we have a new SMB implementation in progress which will be much more robust, and will also add support for SMB3.

We hope to have more news on this later this year.

1 Like

Sounds good.
Looking forward to it!