SMB/Plex/Infuse issue “error loading content”

Read several posts about getting the “error loading content”.

I am getting the same error and my suspicion is that it has to do with access rights handling by Infuse.

I am using WHS 2011 with drivepool installed. Everything was OK, untill a couple of weeks ago. Maybe by coincidence the moment that Microsoft removed SMB 1 support.

Apple TV is set to Auto for SMB. Tried Legacy as well, but noticed no difference.

My workaround is:

Go out of Infuse.
Go to Plex.
Start a movie in Plex.
Go out of Plex and back to Infuse and now Infuse works again.

Probably Infuse handles the logon to the server machine differently than Plex, causing this.

I can access the WHS server from other devices as well, it is only Infuse that shows this behaviour.

One issue that may make it even more difficult to troubleshoot is that Microsoft no longer supports WHS 2011 and hasn’t since April 2016. Not sure how many updates they send out now that impact WHS2011 but it’d be difficult to duplicate the issues with a sundown product.

Have you considered moving up to a current version or another more current server?

Agreed, this one of those stupid issues that you do not know where to start looking for the cause. Now you mention that WHS is not supported anymore and they removed SMB support from Windows, it looks like a “perfect storm”.

Maybe it is time for more drastic measures.

Moving to another server, yes I was/am thinking about it. The hardware of the servers, I am running 3 of them, is also coming into age now. Only issue is the involved cost, we are talking about large amounts of data.

To test, I could swap the OS of one of the servers from WHS 2011 to Win 10 Pro and see if that solves it. Will take some time though…

Not sure what constitutes a “large amount of data” but there are some pretty low cost NAS devices now that work great with Infuse. I run a WD MyCloud and it works great. You can add an additional hard drive off the USB port on that and have a pretty substantial amount of storage.

Not a windows person but the Microsoft Server 2016 seems to fit the bill and has been recommended as a go to for those upgrading from MHS 2011.

Good luck and let us know how it goes!

I really need to first do my homework. Probably I will end up with a NAS. The servers where built by myself years ago (when I had the time). So not really planning to build new ones.

Also having issues with this. I thought it was something to do with Infuse no longer waking the NAS. If I restart the ATV then it works. If I access the drive with my laptop or Sonos it wakes and Infuse works. I’m using a Synology Play 214 with Wake On Lan activated.

Got the same problem after updating to tvOS 12 beta.
Worked fine on 11.4.1 beta. Anyone got a solution for this? Useing W10 mediacenter with plex.

Disable Dolby Atmos.

1 Like

Maybe run Linux on your hardware? I have CentOS 7 running on hardware that is 10+ years old. Installed PMS and configured SMB and I havent had any probs with connecting to shares since I installed the OS about a year ago (even after running updates).

I disabled Atmos and it resolved the issue. To be honest, the only reason I installed infuse was to use my Plex with my Atmos on the Apple TV. Is this an issue that will be fixed in an update? Or is it more of a core issue with the Apple TV so infuse won’t be able to stream Atmos using Plex?

ATMOS support was just released however proper support has yet to be implemented by a large number of developers. There’s already an ATMOS thread on this forum. Follow it for the latest updates.

Ah, just found this thread after posting my own issue. I need to disable Atmos then, as I am on the beta too…

So, just to give an update on my own post. I swapped the OS on one of the machines yesterday from WHS 2011 to Win10 and the error has not been back yet.

So, I suspect that there was some mismatch in SMB protocols between the computers in my network.

Just for the record. I was not running the beta. My issue is/was independent from replies of other users.

Will swap all OS on the remaining machines in the next days.

my Infuse/windows 2012r1 SMB shares stopped working too
given up on trying

Had no issues at all since switching to NFS. May even be faster than when SMB was working. Worth doing if it’s an option for you guys.

Wanted to give an update and still need some advice.

I swapped both Servers from WHS2011 to Windows 10. After several, apparently common, Windows 10 hurdles I am still experiencing issues.

Not getting “error loading content” anymore, but now sometimes a movie just stalls. I read several threads and they all reference Plex. I am not using Plex at the moment.

I blame the APTV4K, because when I play the exact same movie on my Dune 4K, the movie plays without stalling. Or something in infuse?

How to track this one?

Wired or WiFi connection for the ATV? If WiFi maybe try a temporary Cat 5E or 6 cable. If wired try a new cable? I just got bit a few months ago with an “almost bad” Ethernet cable. Changed it and all stalls and lost connections disappeared.

I have a 4K Apple TV connected to a synology server connecting through SMB over ethernet. Infuse has always worked really well for me. Then I upgraded to the Apple tvOS 12 beta. Right after doing so I get the error loading content message. Never happened before the beta.

Have you turned off Atmos in tvOS 12?

All is hard wired with CAT6 cables. As a test I could run a cable temporarily, but I have my doubts since the Dune is on the exact same switch, same cables, all identical. Will try anyway.