SMB on Windows XP drive doesn't work

I am using the latest ATV 2.3.1 with AtvFlash 3.5.1 with NitoTV 0.7.1 (take two) and trying to access WinXP network drive using SMB service. I have set everything and these setting are working on my MacBook, but when I am trying to access this shared folder from ATV I get an error message:
mount_smbfs: mount error: /mnt/Scratch/Volumes/viewed (name of my folder): syserr=Resource busy

Please suggest what to do.

Share the folders on the XP box and follow the instructions below - I’ve just done it and it does work, you need to modify the Network settings under the Nito TV heading BTW…

I’m receiving the same error. The shared resource is called ‘My Documents’ on my server (always at, and I use it easily on my laptop my mapping to ‘//shuck/My Documents’. I tried it with and without authentication. Without authentication I get a ‘tree’ error, with authentication (and my admin-level u/p) I get the resource busy error.

Strange… It works now. I actually think the error occurs when you’ve mounted successfully and try to mount again. I noticed by sshing in and just queried the mount points ‘mount’. Noticed that ‘My Documents’ was mounted and I could easily surf thru. So I went to nitoTV and files, and found ‘My Documents’ listed! Happy day!
So the mpegs play fine, good news. Now I have to see if it’ll stream my AVCHD. Probably not, they’re pretty huge. I wish there was a real-time solution, I really don’t want to have to dumb down the AVCHD. AppleTV outputs in 1080i, and my Panasonic records in 1080i, right? What gives?