SMB not working anymore

Ever since the last update, SMB will NOT work.

No matter what I try, it just hangs on “checking connection”. It used to work 100% on all my devices, but now none of them (AppleTV, 3 different iPads, 1 iPhone) work. Nothing has changed on my share side (MacMini) or my network, so it has to be an issue with Infuse. I can access the SMB share from other things, such as my laptop and other apps can see the SMB share.

Infuse is an awesome app, but I cannot use it anymore. It’s been weeks since I’ve been able to watch any content, and I’ve submitted a ticket and I’ve gotten nothing back.

Please help me fix this so me and my kids can go back to enjoy what was an amazing app.

We’ve seen a few cases where updating to iOS/tvOS 11 requires a username/password to be lost. Can you ensure you are running the latest 5.5.5 update, and then try removing and re-adding your share to see if this helps?

If that doesn’t help, send us a report from your device and we can look further into this.

I am running 5.5.5.

The app can see my MacMini (SMB) when I try to add files, but it just hangs.

I’ve tried deleting and re-adding the share many, many times. I will send logs from multiple devices if that helps.

are you trying to connect using the “smb://computername.local” or a numerical address?

Also what MacOS are you running?

The name is what Infuse defaults to, and what I used in the past. But I’ve done both the name and the IP, neither works. They both just spin after I hit save.

It was Sierra (10.12.6), but yesterday I upgraded it to High Sierra (10.13) to see if anything would change.

I think I may have found an anomoly with the network names and Sierra. Use to be that you’d use the smb://name.local which is what Infuse shows but if you set it up from scratch and use smb://name.home it should work. Replacing “local” with “home” worked for me. If you open the system prefs for Sierra and go to the sharing section you’ll see that under the computer name it says:

“Computers on your local network can access your computer at:
name.local”

BUT

If you highlight the file sharing below that you’ll see where it says “File Sharing: On” and directly below that it says:

“Other users can access shared folders on this computer, and administrators all volumes, at smb://name.home.”

I kept getting the spinning ball too when using the “local” name that Infuse found but as soon as I use the “home” all was right with the world.

1 Like

I tried the Name.home format to no avail.

However, after a whole bunch of trying over and over with different device, names, etc. my iPhone finally managed to connect using the IP. Once it saved, my other devices could see the share because they were logged in to Infuse. It was extra weird because I had just tried via IP again on my iPad with no luck.

My MacMini has a static IP, with manual DNS (as it always has had), with both Ethernet and Wifi on.

I really would love to know the cause of all this since it worked so well before, with nothing really changing.

After the IP worked, I tried again to add a new share via the name, and it worked. It’s nice when things start to work again, but I can’t stand it just working without any clear fix.

And of course, as I wrote that, I deleted the extra share I had made with the name, and it also then deleted my IP share.

Now it will not add back. Same issue as before. This all within the span of 15 minutes.

same here. can not connect to smb shared folder on Mac.
none of these combination does not work.
iOS10/11 to Sierra/HighSierra

Same issue here. 10.13.1 so frustrating grrrrrr

One thing to check (it may be obvious) is to ensure the Sharing name/address hasn’t magically changed on its own. I’ve seen this happen sometimes, and in some cases macOS can end up adding a ‘-2’ to the end of the address…which would break a share connection.

This info can be found in System Preferences > Sharing, as seen in the attached screenshot.

If that doesn’t work, removing and re-adding the share can help in some cases.

Hi,

I’m having issues too. I have a NAS (Synology) with SMB enabled and Infuse fails to read the share. It just hangs for a minute or two and shows and error.
Tried with. my Apple TV 4K and my iPhone X.
I’ve tried to disable and enable SMB. Rebooting ATV. Removing and readding share. Nothing helps
And tested the Infuse user from my Mac and it successfully connects!

Running:
Infuse 5.6.4
iOS 11.2.1
tvOS 11.2.1

Works fine with VLC

Ticket #99408

Cheers

*** Update ***
Seems to be fixed in version 5.6.5

1 Like

Try with another app like VLC and see if it works. Could be the NAS too.

Yes like cecemf said,

VLC works flawlessly in same environment that Infuse does not work.

It works out, after I reset my smb pw.

Here too. Cannot create a share to my synology NAS anymore. Checked this forum to see that HOW LONG nothing happens.
Sorry, but this one is one of the most pricey apps on the store. I gave a one star as review.

Seems to be fixed in 5.6.5

Phew glad I’m not the only one. I’ve been ripping my hair out trying to troubleshoot this problem. I opened a ticket# 99576

I have a Synology (DS716+ running DS 6.1.4 update 3) with SMB shares.
My iPad and AppleTV4’s Infuse is updated to v5.6.5 but refuses to connect to
a known working SMB share on my Synology still does not work.

Synology DSM 6.1.4 update 3
iOS 11.2.1
Infuse v5.6.5

Here’s what I’ve tried.

  • Confirmed my iPad is running Infuse v5.6.5 (1906) and all my devices are on
    the same network.
  • I reset the password for the User on my Synology.
  • Removed the non-working SMB connection in Infuse.
  • In Infuse I added Service (other because selecting choosing SMB auto fills
    the Address field as “servername.local” and won’t allow me to change it.
    Choosing Other defaults to SMB but allows me to manually enter the IP address
    of my Synology Server.

Results.
• I still get an error occurred when Infuse tries to connect. I can connect
to my Synology share perfectly fine from my MacbookPro (macOS 10.13.2)
• Infuse clearly “sees” my Synology as it shows up under available shares.
• One other oddity is I am also running Plex on my Synology. Infuse also
sees the Plex server in Available Shares, however when I connect to Plex and
browse any folders they all show up as empty in Infuse. They are not empty
folders.

Summary:
I want to connect my ATV 4K to my Synology NAS via SMB. That had worked. However, I deleted the connection to change something and now it won’t work anymore.

I tried:
address is diskstation.local and correct
can connect to SMB://diskstation.local from my Mac using the finder
Cannot connect with Infuse from ATV
Cannot connect with Infuse from iPad

I already opened a ticket. Please investigate. I think that its a problem with a NEW connection. An existing connection seem to work.

I’m really surprised. I never received an answer to my open ticket# 99576 nor does there seem to be a resolution posted in this forum. My Infuse Pro 5 is useless.