SMB network share: An error occurred. Not connected to a server

I recently moved my library of videos from a Mac Mini where they were exported as a read-only NFS share to an Ubuntu Linux (22.04) server where I export it via SMB. The entry in my /etc/samba/smb.conf is:

  comment = Movies
  path = /srv/Videos
  guest ok = yes
  browseable = yes
  read only = yes

I can connect without filling in the username or password, and it all works fine, except that I find that when switching back to Infuse I often get the error:

An error occurred
Not connected to a server.

If I press the back button and re-enter the folder it instantly reconnects and shows my files.
I could make an NFS export again, but I’m trying to keep the server’s config as simple as possible, and I’m already using SMB to export shares to Macs.

In general, SMB will often have issues with guest access. So you may try adding a username and password to Infuse to connect.

You can also try adjusting the SMB version in Infuse (try either SMB2 or Legacy under the Advanced section of the share’s settings) to see if this helps avoid these issues.

Thanks. I tried SMB2 and Legacy under the Advanced section, and neither worked.
I added a user and a password, deleted and created a new share (since you can’t change the username for an existing share), but I’m still seeing the same error message. I notice that every time I see the error message and reconnect, I get a new stratos log file in /var/log/samba:

-rw-r--r-- 1 root root   0 Apr 14 17:44 /var/log/samba/log.stratos_f96ea1
-rw-r--r-- 1 root root   0 Apr 14 17:30 /var/log/samba/log.stratos_f85408
-rw-r--r-- 1 root root   0 Apr 14 17:11 /var/log/samba/log.stratos_971c6e
-rw-r--r-- 1 root root   0 Apr 14 16:54 /var/log/samba/log.stratos_c94982
-rw-r--r-- 1 root root   0 Apr 14 16:50 /var/log/samba/log.stratos_200578
-rw-r--r-- 1 root root   0 Apr 14 16:50 /var/log/samba/log.stratos_29e5c5

Are these stratos_XXXXXX dummy machine names generated by Infuse?

I don’t believe these are created by Infuse, but If you want to PM one of them it might be interesting to look at.

There’s definitely a new stratos_XXXXXX file created each time I see the error message in Infuse. There’s nothing to send - these files are empty. Other log files are are simply log. plus the name or IP address of Macs on my network that have connected (no hexadecimal suffix) and contain error messages. I imagine that stratos_XXXXXX is presented as the client machine name by the SMB library you’re using.

Are you browsing directly via folders (not via the Library) and when you see this message, are you inside a folder?

If so, this may be expected because the SMB connection does get cut off if Infuse goes to the background. Navigating around again in Infuse would re-open the connection.

Yes, I’m browsing folders. I forgot about the Library - I have that turned off. The library seems to be useless for me, since I mostly have YouTube videos with local metadata .nfo files I create, and none of them are movies or TV series.

I’ve switched to using NFS, which worked after I manually entered the IP address of the server. I wonder why the NFS share didn’t appear in the list? Maybe it wasn’t being advertised via Bonjour/Avahi?

1 Like

Yes, I had to advertise the NFS service via Avahi. Share now appears in the list in the browser.

Ok great!

Many people report NFS is faster than SMB, so if that’s up and running then it may be the best option to use.

I did test speed on SMB before switching to NFS, and it was about the same. NFS is 576 Mbps on a 1.1 GB file. The Apple TV and server are plugged into the same 1 Gb ethernet hub.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.