SMB DOESN´T WORK

Hi,

I am having problems with smb configuration for the ATV. I have configured smb in my iMac, and it works because I can mount a file from my windows laptop, but when I do it in the ATV I get a mounting error:

mount_smbfs(343) malloc ** vm_allocate (size=3221221376) failed (error_code=3)
mount_smbfs(350) malloc** can´t allocate region
mount_smbfs(352) malloc set a breakpoint in szone_error to debug
and more…

Can anybody help?

Thanks

I’m having the same problem

Can anybody help on this?
It´s seems I am not the only one suffering this problem.
I bought this application because the SMB and AFP capabilities and none of them works
Thsnks

I’m having the same problems here.
Two days ago I purchased and downloaded the aTVFlash software.
One of the main reasons I purchased it, was the possibility to connect to Windows shares (SMB)
I own a AppleTV 40GB and an AppleTV 160GB, both equiped with firmware 2.2
Furthermore I use a Winodws XP (SP3) PC with a share named: APPLE on it.

I exactly followed the manual: http://wiki.atvflash.com/index.php?title=NitoTV_Smart_Installer
to install and enable SMB on the AppleTV.

After that, I used the following settings in: DVD => Network

Enter Mount Name: TEST
Enter Network Path: 192.168.100.160 (IP of my Windows XP PC)
Login type: Guest Login (Guest account is enabled in Windows, and also have right on the share and the NTFS)
Enter Mounting Path: APPLE (name of my Windows Share)

Saved the settings and try to mount.
When I try to connect to the SMB share, my screen shows the following error message:

[color=#FF0000]mount_smbfs(210) malloc: ***
vm_allocate(size=3221221376) failed
(error code=3)

mount_smbfs(216) malloc: *** error: can’t
allocate region

mount_smbfs(219) malloc: *** set a
breakpoint in szone_eorro to debug

mount_smbfs: tree connect phase failed:
syserr= Permission denied[/color]

I also tried with an domain account (registered user) DOMAIN/TESTUSER
but this also does not work. :frowning:

I noticed on the forum that other users experience the same kind of problems,
and no solution for this problem was presented yet.
Can you please tell me what’s wrong and how to solve this ?? :roll:

Thnx in advance

I found this problem, too. I wasted a lot of time debugging this problem. The AppleTV will only connect to a SMB share on a Windows or Linux machine. Shame on you, Apple.

I got around this problem by using sharity – its a s.w. product thatlets you mount SMB shares from various OS X versions. There is a free version that lets you connect to one SMB share at a time. That is the one I used.

Its here http://www.obdev.at/products/sharity/index.html

@macminis4me, so how did you install this on the apple tv?

I followed these instructions but it doesnt work. I can connect to the share from my mac but not apple tv.

The Apple TV can actually connect to a Mac via SMB. You will need to enable the SMB option on the Mac for this first.

This option can seen on your mac in System Preferences > Sharing > File Sharing > Options.

  1. Add the disk you want to share to the list.
  2. Select options.
  3. Make sure SMB sharing and at least one user account are checked.
  4. Follow the guide located at the link below for enabling SMB on the Apple TV, and setting up a manual share point.
    http://wiki.atvflash.com/index.php?title=NitoTV_Smart_Installer

I’ve done all 4 steps but no success. Instructions say the right protocol will be used but I get a message saying cannot connect via afp. My AppleTV is not the original v1 version so smb seems to be my only option. I’m running Mac OSX 10.5.6. I’m not where I can do this now, but does afp in my file sharing prefs need to be unchecked?

I’ve done all 4 steps but no success. Instructions say the right protocol will be used but I get a message saying cannot connect via afp. My AppleTV is not the original v1 version so smb seems to be my only option. I’m running Mac OSX 10.5.6. I’m not where I can do this now, but does afp in my file sharing prefs need to be unchecked?[/quote]

AFP can be checked or unchecked, but SMB will need to be checked.
Updated guide at:
http://wiki.atvflash.com/index.php?title=NitoTV_Smart_Installer#Enabling_SMB_Sharing_on_a_Mac

[/quote][/quote]

My “Share Folders; & Users:” may have entries that are confusing the AppleTV. Otherwise my setup is as shown in your sample. I’ll clean that up tonight and just enter the HD that I want to share and see what happens. Thanks.

[/quote][/quote]

My “Share Folders; & Users:” may have entries that are confusing the AppleTV. Otherwise my setup is as shown in your sample. I’ll clean that up tonight and just enter the HD that I want to share and see what happens. Thanks.[/quote]

I’ve followed the instructions explicitly with no luck sharing my Mac via smb. All I can get is “Network Mount Failed” and then Usage listing that unix gives when using incorrect arguments. I’ve tried shortname, long name, ip address, name.local, and a few other variations which I cannot remember. Are you sure smb sharing works with a Mac. I’d sure like to know how.

I’m also having the same problem. But this is what happens,

Mac connects perfectly to NAS with SMB using guest account. smb://192.168.X.XXX/public/movies
Xbox connects perfectly to NAS with SMB using guest account. smb://192.168.X.XXX/public/movies
AppleTV using XBMC connects perfectly to NAS with SMB using guest account. smb://192.168.X.XXX/public/movies

However, using regular AppleTV with nitoTv following the instructions here: Option 1
http://wiki.atvflash.com/index.php?title=NitoTV_Smart_Installer

I get this error:
mount_smbfs: tree connect phase failed: syserr = No such file or directory

I even get this error after doing a complete atv factory restore and installing the latest ver of aTV Flash. How is this possible if I can connect with my other devices? The only thing I can see that is different is the other devices are set to MSHOME as a workgroup. But this shouldn’t matter as I’m using IP address. I think I might sell my atv and stick with my Xbox, but than I lose my Itunes rental :cry: :evil:

Can anyone help out?

I have the same problem too, except after creating my share point on ATV Flash 3.5, and trying to mount, I get the message, “Mounting Volume Please Wait…”, and it never goes away.

I verified SMB is working to my server as I connected with a computer to it via SMB. Server is a G5 Dual 2 GHz running OS X Server 10.5.6.

This is rediculas, we need a solution fast! i have two windows xp PC’s, one i have set up a share one (tried simple sharing and complex). The share is visible from the other PC but the appletv just gives the following error:

mount_smbfs: tree connect phase failed:
syserr= Permission denied

I have exactly the same problem as onelove - have you discovered a solution?

Is it a permissioning problem?

Nope, no solution yet.

SMB is working. There were a few bugs that were corrected in the 3.5.1 version that was released on 3/2.

The setup process is as follows:

  1. Update Apple TV to 2.3.1, and install aTV Flash 3.5.1

  2. Run Smart Installer to complete installation. http://wiki.atvflash.com/index.php?title=NitoTV_Smart_Installer

  3. Restart Apple TV after Smart Installer completes.

  4. Setup manual share point in nitoTV > Network menu. http://wiki.atvflash.com/index.php?title=Network_Streaming Make sure you have entered the settings correctly, as the Apple TV is quite unforgiving. Also, if you are streaming from a PC, make sure the drive is established as a ‘shared’ drive, otherwise it will not be accessible.

If you continue to have problems, send an email with your nitoTV share point settings and we will help get you going.
http://www.atvflash.com/contact.php