SMB connectivity dropping

Hi,

I’ve noticed a weird bug in ATV Black 1.5.1. From what I can tell, when the box goes to sleep while browsing the movies or while a movie is paused, on resume the SMB connectivity stops working. I’ve tried removing the share and adding a new one - aTV shows the network properly, adds a the network share but that doesn’t work.

Resetting or restarting the device, doesn’t help. The only solution that I found (from this forum) was to install XMBC, add an identical share and start a movie from there. This seems to somehow ‘de-clog’ the SMB connection which starts working w/o any other changes.

This happened to me twice already. I’ve changed the server name from host name to IP hoping that might address the problem. From what I can tell there’s some weird caching going on that gets broken when the device shuts down.

I can confirm the Win share is working fine from XMBC and other machines - the appletv is wired and I can access youtube and the rest. It’s just the SMB share, that used to work great, that for some reason stops working…

 

Any suggestions?

I’ve always found SMB or AFP connectivity temperamental when ATV is waking up.  Usually have to try to browse share 2 or 3 times.  Not sure if it’s because the WIFI is waking up so the SMB and AFP clients try to connect too soon or what.  Happens on both my ATV’s with ATV Flash.  Funny thing is the browsing media on XBMC, i’ve never had this issue.  Always works first time.

Same here. As I’ve mentioned I’m using a wired connection not the wifi. So far I haven’t experienced this in 1.6 but time will tell whether it has been properly fixed or not.

1.6 update dropped my SMB connection!!

any idea?

I have the same problem, but it only happened on 2 of my 3 apple tvs. Uninstalled and reinstalled media player multiple times, removed the share to add it back in but it wont even browse my workgroup. XBMC works just fine. Newest AppleTV OS and Newest ATV Flash Black.

Unfortunately the problem appeared as well on my side. I’ve tried running XMBC (which previously fixed the issue) but as the others reported, XMBC crashes even when trying to add a new share and nothing happens. By looking at the logs it seems the SMB connection for some reason starts timing out. In my case restarting the ATV seems to have fixed the issue but in 1.5 this didn’t solve anything.

Note that now my shares are specifying the connection by IP and I can clearly access the network. Samba works just fine from all the other computers as well.

Are there any command-line tools or logs that I can use to diagnose this problem. Is really annoying since it seems to occur out of the blue.

Same issue here. 

 

I have now tried the following:

1. Reformat and reinstall the Apple tv from scratch, Jailbreak and then put 1.6 onto it - No effect

2. Use XBMC instead - No Joy

In Media Player, the first time you open it, it will see all my movies and begin downloading metadata. When it gets to 20 or so the ATV will just reset itself.

In XBMC when I attempt to add an SMB share, the unit resets itself.

Did you happen so save your settings via Maintenance option and restore them after the upgrade?

I had a similar problems with my Films (no problem with TV Series). I found that if I didn’t restore my saved settings but re-set things up manually (and lose any watched information) then my Media Player behaved OK.

Same problem here. Media Player and XBMC worked fine with ATV Black 1.5.1 - wired network to a Synology Diskstation. After updating to ATV Black 1.6, XBMC crashes when using SMB, using UPnP works from time to time…
Media Player still works.

Have tried the old re-install thing without any luck. 

Thanks guys. No I didn’t save my settings i tried from a clean install and still nothing. Very frustrating considering I just decided to pay for this service. I was using seasons pass and Xbmc for free until now.

Maybe I should take a refund and go back to what was working?

First try submitting a bug report. James is usually responsive and since SMB and XMBC are big issues, I expect him to look into these fairly soon.

Submitted 72 hours ago almost. It’s the weekend though so I’ll give them the benefit
Of the doubt.

I found out that if you have one machine in your home using VPN it barke it.

restart your modem and router fix this issue.

Thanks for the reply but no help there. Rebooted everything, including the ATV,  same issues. 

A new build of Media Player has just been released that resolves the XBMC related issues. You can update on the Apple TV through the Maintenance --> Manage Extras menu.

Sorry for the trouble.

Thanks James, XBMC appears to now be working. Media Player is still not working, it just resets the ATV after about 2 minutes when I attempt to open my SMB share. I had XBMC for free on my ATV before I purchased FireCore. I bought your software because it was supposed to streamline things and make them simpler for my family. Specifically, a media player that is accessible with one click from the main menu. 

When can I expect a working media player again?

Thank you,

Ben

If you’re having trouble with Media Player specifically it may be best to send in a bug report so we can track down what’s going on.

I did that on Friday.

 

http://support.firecore.com/requests/33388

I’ve just escalated your ticket, and replied requesting a bit more information. We’ll do our best to get to the bottom of it.

Thank you, I’ve just submitted my serial number for them. I appreciate the attention.