SMB connections blocked by firewall macOS Sonoma

Infuse 7 on Apple TV 4 is blocked by the firewall of my Mac mini M2 pro under OS Sonoma 14.1
What can I do about it without having to switch the Firewall off.

Welcome to the forum!

Are you talking about accessing it on the local network or remotely?

The Mac OS has had some changes with the recent releases, I’d suggest you read through the revised users guide here.

From a local network
When I switch the firewall off I have full acces once the Firewall switched back on Acces is stopped.
In my MacBook Pro 2015 under Monterey no problem.

Have you updated Infuse to 7.6.2?

Yes I have

Is your user id that isn’t working a “read only” user?

Yes it is

Did you follow the new instructions for file sharing that was updated since the release of the new MacOS?

I did follow the file sharing instructions
Scherm­afbeelding 2023-11-01 om 17.08.10

The problem is: Withe Firewall off everything works ok with Firewall on It Blocks No connection from Apple TV to Mac mini

Did you add Infuse in the firewall settings?

No, How do you do that?

The instructions are on the Apple page I linked to above under the heading " Set firewall access for services and apps"

I just dowloaded Infuse from the App Store on my Mac min and added it to the apps that are allowed to pass the firewall I think I have to restart my Mac and then gif it a try
I’ll let you know if it works.

That did not work only when I switch the firewall of no problems whatsoever

A number of other users have reported issues with macOS’ firewall when attempting to use File Sharing (even those not using Infuse), and it seems the only solution is to disable this.

However, in a typical network environment, a firewall would be enabled on the router which would block connections from outside your local network. Unless you have very specific needs, there is generally no reason to enable a firewall for local network connections.

Ok I can live with that. So I have to wait for an update of Mac OS to tackle the issue
Thanks for your help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.