Smart installer not installing

Hi there,

ATVFlash is up and running on my 1st Gen Apple TV today. Only problem is that I can't get the 'Smart Installer' to install for those extra features that I'd like.

Here's what happens:

  1. It downloads the 10.4.9 Combo update
  2. then it begins (and seemingly finishes) installation
  3. It says 'It's thinking'
  4. Then I recieve an error message saying 'Only partially installed or Failed to install'

Can anybody help me out? I already formatted the Apple TV and tried this again, but got the same result. 

(I'm running OSX [v10.6.6], Latest ATVFlash [v4.2.1] and have a the 1st Gen Apple TV [v3.0.2] )

 

Kind regards,

Karl.

I have exactly the same problem.

I am doing this to be able to stream from my NAS and it appears like AFP network support is not being installed. When I try to mount my mac or my NAS it says:

"Network mount failed! AFT is not enabled properly og missing seessential components, Smart Installer with a 1.0 recovery dmg in -/Documents will fix this issue."

I read on this page that the smart installer should self download everything it needs, so how does it work with this manual install? Ok, it should be located in documents on the Apple TV, but where do I get the file?

Hope anyone can help.

Kind regards,

Hroi

By default the AppleTV will attempt to connect via the AFP protocol, however most newer AppleTV units will not support this protocol. The SMB protocol can be used in its place by setting up a 'Manual Share Point'. We have a guide for setting this up at the link below.

http://support.firecore.com/entries/259299-streaming-files-over-the-network