Slowness, stalling when browsing folders, Plex/DLNA

I’m getting lots of spinning/loading indicators when I browse my Plex (DLNA) folders. Seems very slow on larger directories. Frequently it will simply time-out after a minute or so.

This started a few months ago. This affects the latest Infuse (Pro) on my Apple TVs, iPad and iPhone. It’s only a browsing problem ; playing media is fine and fast.

Back on my iMac, I can see that the “Plex Media Scanner” process spikes to 200% CPU usage (weird) the entire time Infuse is retrieving directory data. CPU usage drops shortly after it’s done, or it has timed-out, or when I close Infuse. Infuse seems to be … requesting thumbnails? building a database? downloading metadata?

Never had this problem until … oh, September? October? of 2019. Prior to that this was all instantaneous. (the native iOS Plex app lets me browse very fast still)

I have 1 Plex library. I keep my media files organized normally. Many directories have 1-2 files, some have 10-20, and a very few have 50+.

Prior to this message, I have : Reinstalled the Infuse app. Re-created my Infuse share. Cleared Infuse metadata. Reinstalled Plex. Re-created my Library. Cleared Plex bundles and emptied trash and re-scanned everything. Etc.

My Infuse setup : No iCloud Sync. Show filenames. No metadata fetching. No collections. Embedded metadata yes/no doesn’t matter. In a fresh Infuse, I add the DLNA server as a new share, then go into --> Video --> [Libary name] --> By Folder, and then I ‘favourite’ this. I don’t know what the ‘Library’ tab is under Settings, but I either see 0 movies/TV shows, or I see ‘Fetching…’ that takes literally forever.

Plex server setup : Any version (1.16-1.18) running on an iMac. DLNA server turned on. Remote access off. Scan libraries automatically+periodically+partial. Most other settings seem normal/default, so I won’t bore you. Native Plex app works fine.

My Plex Library : 1 Plex library declared as “Other Media”. No cinema trailers. No video preview thumbnails. Plex Video Files scanner. Personal Media agent.

Thanks for any advice.

Welcome to the forum!

Have you tried connecting to Plex using the ‘Connect to Plex’ option instead of DLNA? The Connect to Plex option is the newer and more robust connection method, and generally works quite a bit better than DLNA.

Thanks for the welcome. :slight_smile:

Can I browse by-folder/by-directory with the “Connect To Plex” option? I wasn’t able to see it.

I guess that, philosophically, I like the idea of being able to get rid of Plex someday. So I (slightly) prefer sticking to generic DLNA/SMB type options first. (unfortunately SMB on my Mac has been unreliable/frustrating, whereas turning on the DLNA server in Plex is as easy as a checkbox. :slight_smile:

What type of Mac and what problems were you seeing with SMB? I’ve been running SMB for a few years now on an iMac and it’s been flawless. Maybe we can get you back on track with SMB. :wink:

I don’t run plex and Infuse has been everything I wanted from a media app.

Yep, Infuse is great. One of the few media products that’s made just for Apple and not a port of a generic tool. Also, it’s not Plex, ha. Without Infuse my whole media-viewing lifestyle would fall apart. Which is why the DLNA/metadata weirdness was starting to worry me.

If DLNA/UPnP isn’t the way of the future, I can figure something else out. I thought DLNA was faster/more reliable than SMB, but I don’t know where I came up with that. I was worried that I’d stumbled onto a bug in Infuse’s new metadata concept. For funso I tried Jellyfin last night, since I saw it has a built-in DLNA server. But I couldn’t immediately get the share to appear in Infuse (Jellyfin seems pretty beta-y at this point).

I’ll give Samba a look again. I have a few Linux machines where I install it, and every time I have to roll my eyes. It’s so creaky. I thought that Apple’s built-in SMB stuff was only SMB 2, but I see it’s up to SMB 3 now. So that’s cool. I’ll play around with it tonight or tomorrow. If I can avoid Homebrew and smb.conf I’ll consider it a win.

Well, I run SMB 2 on an iMac and it doesn’t miss a beat. All you need to do on the mac is to click on SMB in the network settings and it’s off to the races. No additional software needed. Be cautious using SMB 3 since it has the ability to add an additional security protocol it can cause issues with streaming so make sure if you use 3 you turn that off.

Let Infuse do all the heavy lifting and don’t use a DLNA server. Good luck and keep us posted.

EDIT to add: I meant set up SMB in the Sharing preferences not the Network settings. Under Sharing select “File Sharing” then click on options and there you enable SMB.

You can also use NFS to serve out content. Less overhead than SMB.