Slow streaming speeds with big files from MEGA

Just a quick suggestion, better playback for bigger video files (30gb and up) seems the bigger the file the more of a chance of lag or slow down, high quality files like 4k 7.1 atmos mkv play great in general, but sometimes also suffer slowdowns.

I have a huge collection of 4K HDR/DV remuxes some close to 80GB and have never had lag.


Not sure this is really a suggestion. As @Hitsville said and many others most files play fine.

If you’re having an issue with certain files you may want to post the specs here and maybe we can figure out what you’re running into.

Listing the device you’re using and what version of Infuse along with what protocol you use to connect and if it’s WiFi or wired will help.

1 Like

I also have some files ~80GB and I never had any problems, even scrubbing works normally without any lags.
My ATV as well as my NAS are both connected via Gigabit LAN.

What does the speed test give you when the run it dude?

You can select a given file from your share to test it against, you ‘should’ get the same speed test result more or less for any file but you could run it against the problematic files and ones that dont lag to see if there’s a difference?

I have files around 100GB using h264, h265 which always respond instantly to scrubbing on Gigabit lan, so perhaps see if the speed test gives you any idea if there is a network drop somewhere or performance issue on the remote device sharing the data, such as a bad HDD or simular.

Yea that’s strange huh ?I’ll definitely look into it now It has been a off and on ongoing issue for me since I got infuse pro. Like the guy above said, I’ve too also have big files that work fine, but not all the time. I checked to see if it was my internet, on pc the files have no lag. But on my tv and iPhone 13 Pro Max it’s hit or miss sometimes. Tv is a LG 4K TV capable of hdr, 60fps, 4K, Dolby vision, however I do use a Apple TV to use infuse app since it’s not on the Xbox store, I can’t use anything else to check. I always use the latest firmware of infuse, I couldn’t find anything on settings for playback I can start there if I can find it and play around and see if that helps

So I tried the speed test but it literally would have taken me 40-1 hour to finish it, I stopped it at like a minute and said I was performing better then average so that just confused me even more, I normally watch on my phone 13 pro max, and on tv I have the older 4K Apple TV from like 2020, so I’m not sure if it’s my device or my internet connection or just settings

The speed test in Infuse should only take a fraction of the actual duration of a video to run 100%. What do you mean by "better than average?

Try letting the speed test run to completion on a movie and post the results here with a screen cap of the graph so we can see a bit better what’s going on.


Just to make sure, are you using the Infuse speed test correct?

Poor scrubbing on the iPhone could be down to Wi-Fi, tbh I get that from time to time on bigger titles, but I don’t often watch a UHD HDR film on my phone, but I certainly need to be getting decent Wi-Fi bandwidth at the time to do it, iPhone 13 mini.

It’s important to let the speed test complete, you’ll see a graph at the end, if you see massive dips those I guess would relate to something.

Ok so here’s the speed test, currently been about 5-8 minutes and it’s at 4 % which is what I meant by taking a long time and to clearfy your second question as you can see there are 3 speed readings

Average Speed
Current Speed
Minimum Speed

Though it looks like they won’t be accurate until the speed test is over, so it’s irrelevant, im performaning it on the 4K Apple TV with the latest update on both

How are you connecting the ATV to the LAN? Ethernet or WiFi? Those speeds look like either poor WiFi speeds or one of the lower speed Ethernet protocols.

What does the graph look like for the test you ran?

Ethernet would be 10mbps or 100mbps if we’re talking about the old Base 10 and 100, with his test coming out at 20 something mbps even USB 2.0 is quicker than that.

Gotto be Wi-Fi surely OR a remote server with a slow upload speed.

Not necessarily. That’s why I asked. We’ve seen several cases of old Ethernet switch rated 10BT and some cases where the cables were faulty or just old. That’s the reason I asked about it first then will work on it once we’ve narrowed down the possibilities.

If dude is using a Base10 switch when he has a lovely TV like that ill never post on the forum again, that’s my bet :slight_smile:

1 Like

I only use Wi-Fi, from my Internet provider nothing fancy just connect device to wifi and that’s it, I have to wait until the test gets done to see graphs or results by the looks of it, another hour or 2, and that’s the wierd thing I can literally watch this exact video file on my old pc with no lag or issue with the same internet connection, VLC works great but once I try to use infuse it will randomly start lagging throughout the whole movie. I put my files in mega to save space and use infuse from there. If it was my wifi wouldn’t I have issues streaming In general ? it’s not all the video files only some that have this problem.

My only work around is to download the files back to my pc and watch it from there while it’s hooked up to the tv, which I use to do back in the day before I started running out of space. What settings can I play with on the infuse app to help with lag ?

Hmmm… I’m very interested in this actually, so let’s say I have the slowest wifi in the world, but play a video in vlc on my pc with no issues, then I try to play that exact video file on a different video app with constant lag…what would be the best bet to figure out what’s reasonable for this strange outcome because I’ve been trying to figure it out for a year, By the way I don’t have the worst wifi lol it’s like in the middle it’s called blast something on xfinity but yea I use the home wifi for everything so that’s the only setup, it lags on my iPhone and Apple TV for certain files, other files it’s fine as normal.

Ok so bad news is the big video file stopped because the tv turned off, the ok news is I tried the test on a file that never gives me problems and like you said it probably took me like 3 minutes for it to complete, so that’s good. Here are the results of the good file

First, I didn’t realize you were streaming from mega so the internet lags also come into play.

You shouldn’t see the down spikes to zero when streaming it’s no wonder you’re seeing problems at times.

Have you tried some of the different settings for the streaming cache?

Some routers also have settings that give different devices streaming priorities so you may want to see if there’s so settings in the router that may limit bandwidth to Infuse on the ATV but not limit your pc.

Also, WiFi on the Apple TV will be max out at lower throughout than most computers since it has fewer radios and concurrent wifi connections.

So you’re in effect using Wi-Fi plus a remote server? Would explain the performance issue.

Wi-Fi on my 4K ATV used to do some odd things, unrelated to infuse. I used to run Wi-Fi in my daughters play room and the Wi-Fi performance was totally garbage, which I found strange really considering it was an Apple product. Sometimes it would become unusable, I’d have to power cycle it the suddenly it was normal again. Happened to often, eventually just managed to get Ethernet to it.

Go to the ATV App Store and download ookla speed test, this will test your internet bandwidth, be interesting to see what you get and if it’s a lot higher than the infuse speed test. Point is to compare the result to the actual ISP product you have and if the Wi-Fi performance is the issue. If you have a 300megabit service and the Wi-Fi is spoiling it then you’re gonna need to improve the Wi-Fi or run a cable.