Slow speed via Ethernet

Hi all

I’ve recently invested in a ATV4K and Infuse Pro. I’m very impressed with the setup and have invested in a lifetime sub, and so far so good.

The one issue I need to figure out is the streaming of my 4K UHD content. Each speed test I run tops out at 50-60 mbps, so not good for high nitrate content.

My setup is currently:
Virgin Media Hub 3 (router)
Windows 10 Intel Stick PC (CORE M3-6Y30)
USB/Ethernet adapter
10 TB Seagate External Drive via USB 3.0
Drive shared via Windows File Sharing (standard protocol)

The Ethernet adapter goes into a 1000mbps rated homeplug, and the other end goes from homeplug to ATV.

Obviously I’m thinking the usb/Ethernet adapter may be holding the speeds back, but I’m also thinking of trying FTP.

I’ve set up FTP on the Windows 10 machine, added the folders to share… but then I can’t figure out how to actually access it. I know that probably sounds so stupid, but how do I get my ATV and iOS to see the ftp server on the PC?

I guess my other question is whether there’s anything else I can do to try and push up the speed within Infuse.

Thanks in advance for your help!

Hi,
You’ll find the ftp option in preferences, shares, then scroll down and you will find it under other.
This worked as correctly my zyxel nas.
Anyway you should find out, why the normal version doesn’t work. There must be some bottleneck. Doesn’t have your pc an Ethernet or usb c plug?
I am a Mac user, so I don’t know about configuring PCs. But there should be a way, to get smb to run properly.

Thank you! I figured out how to access the ftp via a browser and that works, but what address do I put in the Infuse settings? I haven’t set a password or user. I’ve tried putting my IP in there but Infuse shows an error when I try to connect.

Hi, as I said, I am not experienced in windows.

With my Zyxel nas, when I am in the ftp Setup in infuse,
I put in the url of the nas.
That is the url, that every computer or device has in your network.

Like 192.168.178.xx. The first three groups of numbers are typical for a fritz.box. The xx is the individual number of your device, that you want to use. Meaning your pc.
You should find your url in your pc and in your router as well.

Then the user and the password of the nas.
And… there you should go.

Network is not an easy thing, if you are not used to it.

It really isn’t easy :joy: thanks for your help, hopefully a windows expert will be able to help me further. I find it all quite confusing, I just wanna stream my UHD :joy:

Yes, I can understand you. That’s why I use Apple. It’s easier.
Anyway you should try to bring the normal smb version to run.
If that doesn’t work properly, ftp might not run as well.
The problem is, that everyone’s configuration is different.
Therefore it is difficult, to offer 100% working solutions.

Try to use some „server“ app. For example emby.
With emby you can manage your content and infuse support emby log in.

@mythuk Just a suggestion but you may find some answers in the users guide here


Look under the section labeled Windows 7 & 10 for a link to setting up sharing.

@NC_Bullseye Thanks, I’ve had a read and I can get so far. I’ve added a new FTP share along with IP, also MAC address under Advanced. There’s no user name or password (I didn’t add one during FTP setup). However when I try to connect Infuse throws back an error saying user name and password combo isn’t right.

I feel like I’m close but just some way off figuring it out!

Did you set the access to “everyone” on the server as per the “Share an item on your network” section?

@NC_Bullseye yeah, with read/write permission. I double checked this is the security settings too and made sure file sharing was on in the settings too

I’ve been playing with the FTP side of things and the issue seems to be that Infuse can’t authenticate to access the FTP.

I can access the ftp via Safari on my iPhone and via VLC on my phone, so it does seem to be infuse specific.

Anyone got any suggestions?

It’s the homeplug/powerline adapter (thats the device that uses the house wiring to carry the ethernet data). You’ll never get anywhere near the advertised speeds in real-world situations.

Tinkering with different protocols and settings is unlikely to help much.

Get a long enough ethernet cable, and use that instead of the powerline ethernet adaptor, and see how that performs in the speed test.

I know what you’re saying but I’m not convinced that’s it. A rating of 1000 Mpbs shouldn’t equate to real world performance of 50 or 60 Mbps, overheads shouldn’t be that big!

Also the same PC hosting my files can download from the internet at 110 Mbps using the same home plugs, so I know they can handle that, at least.

Those intel sticks are notorious turds when it comes to doing anything “server” related. Not enough ram and the processors are too slow to handle fast SMB. They’re meant for light work duties such as kiosks, web browsing or display boards. You might be able to push more performance out of it if you can install Linux on them.

I have no experiences with those sticks. But looking at the specs, I can well imagine that it is the bottleneck.
When you stream through it, you are using two directions. From the drive to the stick and from the stick to the network.
That is definitely more work for the stick to do.
When you are downloading, it is only one direction.
Also, a 4K und movie could have peaks that are higher than 150 MBs.
The stick seems to have three usb c plugs. But maybe they are not independent from each other, and act more like a hub.
Anyway I would try to find a different option, like a Mac or pc or an nas.
A small nas would be the cheapest and also most efficient solution.
You can attach your drive via usb, and don’t need to take care for all the nas things.
If your drive is formatted to ntfs, you can go right away.

Thanks guys. I have an old PC (Asus Eee Box EB1036) and I’m just this minute reading about wiping it and installing OpenMediaVault on to it to create a homebrew NAS.

I’ll play with that and see what happens, but if all else fails I’ll have to put my hand in my pocket and buy a NAS :joy:

Yes, you can get a simple nas, put one drive in it, maybe you have an old one.
You don’t need to configure it as a raid system. Just a single disc.

Then you add your usb drive.
Take care that the nas has gigabit Ethernet. Otherwise you are in the same problem again.

Yeah the old PC has a gigabit Ethernet port so hopefully that won’t be an issue.

I’ll see if I can try it tonight, just a simply disk share as you say.

Thank you!

It should have usb 3 or c as well.