Slow Speed Test on Plex Share vs SMB Share

A few months ago I switched to Infuse and bought Pro subscription simply because the app seemed much better at playing various content (especially DV) compared to Plex which is my media library. Since I already have lifetime Plex subscription, it seemed logical to let Sonarr and Radarr handle everything into Plex and then use Infuse as a superior player. For a while it worked great.

Some time ago, I started to get constant buffering in Infuse. Since I was fairly limited with my spare time I simply switched to Plex for a while, but now it’s starting to bug me, because I’m not sure whether I should renew my Infuse subscription or not.

I did some testing and came to the following conclusions:

  1. Everything plays on Plex just fine.
  2. Infuse speed test on Plex share shows average of 20-30 Mbps, which is rather low.
  3. Infuse speed test on SMB share (of that same folders Plex uses) shows abour 250-350 Mbps and plays content flawlessly.

Everything is wired via 10Gbps ethernert (well, Cat6, but cables runs are shorter than 10m). I’m using both apps on Apple TV 4K. When playing content from all three sources (Plex, Infuse via Plex, Infuse via SMB) it shows direct play every time. My only guess is that something is throttling the connection when connecting my PMS to Infuse but I’m stumped as to why… Any idea what might be causing this? Maybe someone had a similar issue?

Thanks!

Welcome to the forum!

There are many things that can affect the speed of SMB connections and you can find the trouble shooting guide here.

Also you could look at setting up a FTP share if that doesn’t help.

Thank you!

But my SMB connection works great, it’s not the issue. I simply don’t want to use it, but rather use my Plex Media Server and it’s working slow, even though it’s working from the same folders and both apps are on the same Apple TV, hence my conundrum.

Sorry bout that! Misread it as the SMB being slow.

You say you’re getting slow Plex speeds but is it causing problems with playback? If it’s playing ok then Infuse may not need to pull any faster.

As to this, Infuse does not transcode. It will always play the original file.

Sometimes plex enables the relay and starts piping everything through that even though you’re on your local LAN. Disable plex relay and try again.

2 Likes

No worries! But yeah, the playback is pretty bad, most of it time it’s stuck on long load times and even if it starts playing it will start to buffer in intervals. Usually it will spend more time buffering than playing, especially with big files.

I’ll definitely try that, but will it mess up my ability to watch content when I’m not home?

Also, I’ve noticed an interesting thing last night when tinkering. I launched both Plex and Infuse on my phone and the same thing happens. BUT when I turn off wifi on my phone and try to use the apps, it’s the Plex that can’t play and Infuse works without hiccups, so I’m even more confused now…

I have the relay disabled. It’s only used if you don’t have port forwarding enabled on your router.

1 Like

I’ve tried it and it did help! The speed test shows higher speeds now, although it is still slower than SMB. I did notice a couple of strange things in my followup tests, though.

I used a remux LotR for testing and Infuse works on Apple TV, it also works on my iPhone via WiFi where it occasionally buffers and it works via cellular (didn’t notice any buffering).

Plex works fine on Apple TV, it also works on iPhone via WiFi, but it absolutely refuses to start when I’m on cellular (but that’s not related to Infuse, just mentioning it because it might give a hint to some wider problem).

What’s most peculiar, though, are the IP addresses when playing. I’m running PMS on my server in docker (via Dockstarter), along with other apps like Sonarr, Radarr etc. Although my home network and VLANs are in 10.x.x.x range, my docker range is in 172.18.0.x range.

Now here comes the kicker:
When I play on Plex via my iPhone (wifi) it shows “local” and my iPhone IP address; when I play on Plex via my Apple TV (wired) it shows “local” and my Apple TV address; but when I play Infuse, whether iPhone or Apple TV, wired, cellular or wifi, it shows “local” and my docker address 172.18.0.1.

It makes no sense to be because both apps are ran on Apple TV and on iPhone. I’m aware that this is probably more related to my Plex settings, but it could be pointing as to why the lower speed occur in the first place.

Hope someone can shed some light on it because I am stumped…

You stated you have multiple VLANs? Is the routing happening on the router or do you have a layer 3 switch handling everything? Does your router support NAT hairpinning/loop back? I find routers that don’t support this think everything is coming externally so all traffic is pumped out the WAN and back in again. Try disabling remote access in plex. If speed increases then you have a a routing/NAT issue.

Good questions!

I have a Unifi UDM Pro with a 24 PoE switch. I’ve created multiple VLANs, but have created firewall rules and opened up ports (using mostly advice from this sheet), so it has been working well for a while until recently and I haven’t been changing anything in the setup. I also must admit I am not aware whether UDM Pro supports NAT hairpinning/loop back, but I’ll certainly investigate.

I’m still confused as to why would two apps that are installed on the same machine (Apple TV) report two different IPs while playing content. Perhaps because Plex is playing directly from PMS? But isn’t Infuse connected to PMS as well?

I think they both do the discovery and internal handling a little different. The UDM should do hairpinning as I’m running an UBNT edge router as my firewall and it does… but they are two separate product lines so who knows. You can see if it’s doing an improper loop back by watching the bandwidth on your router. When doing a speed test if your WAN bandwidth also spikes then you know there is something funky going on.

Could be, perhaps Infuse “plays” directly from the source (docker PMS), while Plex media player gets everything to Apple TV from the source (docker PMS). Infuse never transcodes and I love that, Plex will Transcode audio sometimes (i.e. TRUEHD 7.1).

But as for the router, do you mean speed test from the UDM Pro? Always runs smooth and within expectations (I’m running fiber 1Gbps up, 500 Mbps down). It’s only the Infuse speed test to PMS that tends to be lacklustre, while the SMB speed test to that same library goes well, as well as the speed test from Apple TV to WAN (via Ookla).

No. Here’s the steps to follow:

  1. Login to your UDM so you can monitor traffic across interfaces.
  2. Start a Speedtest in infuse from a device to your plex server.
  3. Look at the UDM. Normal traffic should flow from one lan interface to another. There should be no spike in activity on the interface connected to your internet (WAN). This proves that traffic is flowing properly and staying within the LAN. If you see a spike in both upload and download on your internet interface then there is a problem.

We’re not trying to find what the problem is but what it isn’t.

1 Like

First of all, thank you so much for troubleshooting this with me.

Second of all, at the risk of sounding like a noob, how can I monitor traffic across interfaces from UDM? I can see upload and download traffic, but can’t find anything on the dashboard to monitor local traffic.

In other news, even though I have touched nothing within Plex settings, the speed dropped again and Infuse is buffering again intermittently (every 2-3 minute on a 4K TV show). The only thing I did in the mean time is updated my two PiHoles that work in high availability mode (the have a shared virtual IP address), so now I’m thinking maybe that could be the issue?

Forgot to mention that both PMS and Apple TV are on the same VLAN so there shouldn’t be any problems there, I suppose…

I’m not entirely sure how to monitor the traffic from the UDM (I don’t have one… only have an edge router which uses the UISP app). I guess if there isn’t an option you can always just unplug your internet connection to see what happens.

If you really have a bunch of spare time you could spin up a network monitor system like LibreNMS and connect your router/switches/etc into it and do snmp monitoring with that. That might give you a more accurate picture as to what’s going on in your network.

1 Like

I spent a day monitoring everything and I think I figured out a part of the problem.

  1. I’m running PMS (and bunch of other stuff) via Dockstarter, because I’m a docker noob. What seemed to be the problem was that while Plex app will connect directly to PMS, Infuse had issues because of the docker. I’m currently in process of setting up Macvlan networking in hopes that that would solve it. Can’t really say it’s working, because I’m getting some odd results like:
"docker network create" requires exactly 1 argument.
See 'docker network create --help'.

Usage:  docker network create [OPTIONS] NETWORK

Create a network
  1. I removed my HA PiHoles from DNS temporarily because I’m planning to replace them with AdGuard setup over the weekend.

Writing this in case someone else runs into similar issues so that they at least have a starting point. Also, special thanks to @JarvisMeier for patiently providing me with advice :slight_smile:

1 Like

Awesome I’m glad you’re making progress. One other thing to note is because you have multiple vlans make sure to specify which networks/subnets to treat as LAN in your plex server settings. If you don’t set this plex will only consider the subnet that the server is on as LAN so it’ll automatically apply external bandwidth settings.

1 Like

Yep, already did that, good thinking! I even tried removing some of the VLANs and it automatically switched to remote streaming (albeit still direct). Macvlan netwroking for docker really helped, but I also suspect piholes had some role to play as well… I do plan to switch them out for AdGuard Home or NextDNS over the weekend, but if anyone is using PMS over docker and trying to use Infuse, check whether your docker is bridged or hosted. If bridged, setup macvlan network :slight_smile: