Slow SMB Streaming from Mac

Hey,
New user here. I’m running the latest version of Indusion 7 pro. I am file sharing from a M1 Mac mini with SMB.
According to Black Magic, the read and write speeds are 250 Mbps. The speed test from within Infuse is about 50 Mbps.
The AppleTV connects by WiFi 6. Using the Speedtest app, I get 200 Mbps connection to the internet.
The Mac mini is connected by cat 5e cable to the router.

Any ideas why the transfer from the Mac mini is so much slower?

Thanks!

Welcome to the forum!

Is there a problem with viewing the videos? The speed test in Infuse is not a full bore network speed test, it tries to simulate what a video would require and has overhead.

Unless you’re seeing problems with viewing videos don’t worry about the lower than max network speeds reported by Infuse. :wink:

Hey, it buffers about every 10 second unfortunately

Okay, what version number of Infuse and does this happen on every video or on certain ones? What model of ATV and what tvOS?

Could you as a test, try connecting the ATV with an Ethernet cable instead of WiFi?

What do you have the streaming cache set on in the Infuse setting?

Infuse Pro version 7.3.10
AppleTV 4K 64 GB. The newest release model. tvOS 15.5 (19L570)

Unfortunately, I don’t have a > 20 ft ethernet cable. I could order one, but even if that worked, my wife would never let me have it run from one room to another, and the wall the TV is mounted on is above a bricked fireplace, so I can’t run it through the wall. I don’t have a tv in the room with my modem and router.

It happens with all video files. I have ripped 1080p Blu-ray’s with makemkv with no compression.

Streaming cache is set to Auto

MacOS is Monterey 12.5

The Ethernet cable would be only to rule out the WiFi as being part of the problem, a temporary test. I’ve seen many instances where the WiFi “looked” good in numbers but was less than optimal in actual streaming. If the Ethernet cable didn’t work in the test then it’d be back to looking for the issue with either the files or settings.

Another easy test, try changing the SMB version on the ATV from Auto to Legacy or SMB 2 in the share details. I’d suggest trying Legacy first and if that doesn’t help try SMB 2. Now this is different from the streaming cache options. Here is the users guide that details this.

Thank you!

I’ll try Tempe Ethernet cable. Trying smb2, smb1, and legacy didn’t make a difference. Thanks fir your help!

There is one more setting that you could play with to see if it has an impact on your issue.

The Streaming Cache in the Playback settings in Infuse, It should be on Auto by default but I’d also try “Memory Only” first and then try “Legacy”.

50Mbps average is not going to be enough for those. You should shoot for closer to 100. This would allow for some dips but not enough to cause issues during playback. WiFi is most likely the problem. Now can you confirm you are connected to a 5Ghz signal? Sometimes my old atv would connect to 2.4 which would limit the speed significantly.

Take a look at this thread and my comments, infuse smb implementation is not good performance wise.
Your options are either 1) wait and hope infuse dev will come up with a better smb & sftp implementation 5 years later, 2) Ethernet, 3) better wifi

Hi All,
I’m so thrilled and welcomed by everyone stepping into help. I’m hearing the problem is either my WiFi or infuse’s SMB implementation. If it were slow WiFi, though, wouldn’t Ookla’s Soeedtest also be at 25-50 Mbps? I get at least 250 Mbps. Granted, that’s internet speed, but since the app is running on the AppleTV 4K the information still has to travel via WiFi, right? So it shouldn’t be the WiFi, or am I missing something? The Mac is connected by cat 5e cable to the router.

I’ll also tried setting the cache to Memory, but there was no change. On Legacy I got about 8-10 Mbps faster for 10 seconds, but then it dropped to half of its usual speed.

Thanks, everyone!

You could also try setting up an FTP server on the Mac and trying that with Infuse. That would be a quick test too. Many users run FTP servers.

Thanks All!

Here are some details as the difference between an internet speed test and infuse

The speed test feature in Infuse is not just used to measure the simple transfer speed (IE copy a file as fast as possible). Instead, it will replicate the transfer speeds available during playback as during the test Infuse is actually working to transfer the file AND play it (in a hidden window) at the same time. This provides a much more accurate representation of the speeds you can expect to see during playback, as transfer speeds will be impacted by system load.
Additionally, on iOS we are using multi-threaded connections when downloading files for the fastest possible speeds. However, these are not used for streaming since they add to system load, can impact playback quality, and are unnecessary.

Hi All,
It must be something with SMB. Using Plex Media Server, the transfer rates are over twice as fast.

That’s typical. Plex protocol is designed specifically for media streaming. But if that means only 100Mbps for Plex then there is probably a network issue as that is relatively slow.

Did you try an FTP share?