Slow SMB speeds but max UPnP/DLNA speeds between Windows 10 & Infuse 7 on ATV 4K 2nd Gen

I know this has been asked many times over time but I’m not able to get any solutions for this yet. I get max speeds over UPnP/DLNA like 350-400Mbps but only 50-75Mbps with SMB. Tried Legacy mode and the speed only increases to 65-75Mbps from 50Mbps. Both SMB1 and SMB2 is enabled on PC.

My router is R7800 and a Laptop with AX200 Wifi card. Both ATV and PC is connected to 5Ghz and the link speed is ~866Mbps and ~845Mbps on ATV. Most of the high bitrate movies buffers many times while streaming.

Are you streaming from laptop to Apple TV? Try connecting them both to Ethernet and see what speeds you get. Even if you can get link speeds that fast it doesn’t mean you can stream a movie that fast.

Also note you will lose much of the benefits of the Library function with UPnP/DLNA connections.

Why are you concerned with speeds? Are you having playback problems? If so with what type of file?

Did you try setting the SMB on the saved share advanced settings in Infuse to SMB2 instead of legacy?

Yeah that is why I switched to SMB but its slow

Yeah. Some higher bitrate movies like 4K HEVC files and some 1080p files buffers in the middle of the streaming.

I have tried all. The speed only jumps to 10-15Mbps with different each settings. That’s it and no much improvements.

Although UPnP/DLNA speeds are just fine. Pretty weird

Did you try changing the “Streaming Cache” in the Infuse settings under playback to “Legacy” instead of Auto? This is different from the SMB related settings.

Yes already tried that many times back and forth!

You know how to trace data through ETW like this? Slow SMB/CIFS performance - Microsoft Q&A

I had this issue for a long time. :frowning:

You still have this issue?


My laptop’s Wifi speed is literally faster than it’s ethernet port(which is only 100Mbps)

Yeah I know it’s 433Mbps up and 433Mbps down. But if it can reach ~350Mbps through DLNA/UPnP then why not on SMB?


Could you try connecting via SMB instead of DLNA/UPnP?

This will generally be more reliable as Infuse has direct access to the files instead of relying on the DLNA server to provide the correct list of files.

Hey I have already tried SMB but… Slow SMB speeds but max UPnP/DLNA speeds between Windows 10 & Infuse 7 on ATV 4K 2nd Gen

You can try using FTP connections to solve this problem; FTP connections are faster than SMB but do not have the hassle of UPNP connections :no_mouth: :no_mouth:

Were you ever able to solve this issue? I can’t for some reason use FTP with my old rn4000 V2 nas, as it always says my username and password combination is wrong (it doesn’t allow for anonymous access) but smb is around 55mbps which sucks. I’m wondering if my router is the bottleneck? It’s an old 2888a D-Link model Maybe it’s dragging down the smb speeds of my nas?

Switched to Emby on my Synology NAS(still use SMB sometimes) and the speed reaches to max like 700-800Mbps! Using Emby with Infuse has few caveats like no search function, no folder browsing and few more but is sure fast.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.