Slow/Non-existent Movie Streaming: Why, and How to Fix?

I used to have no problem streaming movies from a networked drive to my Apple TV. Now, they either don’t show up at all, or they hang after a few frames. Anyone know why?

I’m running ATV 3.02, and ATVFlash 4.02, the movies are on an external Firewire drive attached to my Mac, and I’ve always aliased them through iTunes – that is, I do a drag-and-drop of the movie file into the iTunes movie screen, where it creates an effective alias of the film. In the past, this worked fine. I’d click on the film’s icon in ATV, there’d be a pause as the movie loaded (with the blue bar across the bottom getting filled) and films pretty much ran without pause (maybe a hiccup or two) through to the end. Now, I might get a peek at the blue bar, but the screen pretty quickly goes dark, and I rarely see a film.

All else seems to be okay. I know the network is working – movie trailers, Podcasts, and the like stream immediately and without problem. Music generally streams okay. But longer files like films or even video podcasts that are stored on and streamed from my networked drive – no go. Any ideas what I can do?

So after trolling around, I found the best work-around: Set up an extended wireless network using an Airport Express, and then attach the Airport Express via ethernet cable to the Apple TV. It’s explained here:

Yes, I know that streaming should work fine on it’s own. But apparently, something in iTunes 9 has really impeded streaming. And using the Airport Express as a wireless-cum-wired booster is AMAZING. It really brings out all the capabilities of ATVFlash. I highly, highly recommend this approach.

I had the same problem of slow or no streaming. I have the latest version of ATV sw and ATVFlash 4.0.3. Tried everything. Good improvement after having disabled the AirControl support under the plug-in maintenance menu as explained in other posts. After this change I was able to stream normal movie in low definiton but still a lot of breaks in HD clips (either 720p or 1080p). I then bought an Airport Express to connect via Ethernet to the ATV and wireless with the TimeCapsule as suggested here. No changes (difference from randall) but following his links I’ve found the solution to all my problems.

Here is clearly explained that there is a bug in the more recent formware of the Aiport Extreme and of the Time Capsule. The latest working firmware is 7.3.1; with that the streaming from network disks is fluid as it should always be even without the Airport Express !!!

So I need now to find another way to imply the Airport Express for not wasting 99 Euro but hope the solution can help some others.