Slow backward and forward (no cache?)

Hi,

I was using Plex app a lot in my iPad , and now I’m starting with infuse. In quality of video infuse is better, but in experience can improve a lot (Plex app is really well made)

One thing I noticed is cache:

  • if I minimize the app and open again, appears the loading
  • if I go backward or forwards, ALWAYS appears the loading

If would be better if some content is cached temporary and so the experience would be more fluid (avoiding loadings)

I bought the lifetime subscription, so I really want infuse to be better that any app (including of course Plex app), anyway I’m really happy with the app :slight_smile:

Is this while it is playing, or just the browsing the app? It will show loading indicator whenever it does have to load new content. In the background, as long as you have background playback turned on, shouldn’t show the loading. If going forward/backward and the data isn’t cache, then it will have to load. Once cached, you may or may not see loading depending on how fast it can switch.

I meant when a movie is playing. I have activated the playback option in my iPad and seems like anything is cached, the loading indicator always appears (even if the content is downloaded or not)

Ps: using iOS 13 beta 4

Are you able to test this on a device running iOS 12 to see if the same issue is present there?

I just test in my iPhone XR iOS 12 and is the same. The loading appears a lot

I’m attaching a video:

My guess is that your WiFi is not good enough so no caching is really happening. When you fast forward it goes 30s, then back 10s (+20s). Then leave and back (still “new”). This behavior seems consistent with caching not happening. Is this the 4K version or HD? 4K pretty much guaranteed not to stream well. Even with what you expect is fast enough WiFi it could have issues streaming well enough to cache.

Try a really short movie (Pixar short, etc) and see if you can see the cache indicator advancing. It’s hard on a full movie.

As I said this happens also when the movie is downloaded in my iPad, so I think is not a WiFi issue (I’m using 5ghz in the same room)

Btw, my movies generally are: 4K HDR x265

Well it does take some time to process file to seek to the right spot and get the audio and video ready. Try with HD and it’s much faster than 4K.

Are you sure you are playing the downloaded files? Even with a file downloaded, it’s still possible to browse to the remote copy and play it.

To ensure you are playing the downloaded copy, look for the word ‘Synced’ which will appear below the video’s title on the details page.

I downloaded the movie, shut down the Plex server and event tried with airplane mode, and is still happening (also tried enabling/disabling background playback)

Here the sample, hope it can helps
[link removed]

Ps: the same movie in Plex app (without sync) cache very well, and there is none loading time there

Thanks. The video is helpful to see what’s going on.

I wasn’t able to replicate this here with the samples I tried, but if you have a chance, would you mind using the ‘Email Us’ option found in Settings to open a support ticket so we can look further into this?

Done

Just a thought, have you checked under your ios settings > battery > battery health> and see if “Peak Performance Capability” has enabled performance management?

That will affect video playback and other processor intensive functions if it’s been set to on.

It’s normal i think, also this happens in my iPhone and iPad (iPad doesn’t have battery health I think)

Yup, looks fine. That was just a long shot on my part. I’ve seen that be the cause of other issues in the past and it was a bear to find.

I’m sure James will track it down. :wink: Thanks for checking!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.