SlingPlayer Plugin+Firefox -- Need root access?

So, I recently got Dish Network service for my home. Part of the reason was the ability to use the Sling adapter for the 722k DVR to access the programming/recordings from anywhere. This would allow me to use Firefox on my Apple TV1 to see the DVR recording in my bedroom. Problem is, I need to install the SlingPlayer Plugin to the Apple TV and it’s not working. I used CyberDuck to FTP to the ATV and copied the Sling Player Plugin from my desktop Mac to Library/Internet Plug-Ins, restarted everything, then tried. Still, the Dish web site states the Plug-In needs to be installed. I then tried an SSH connection which gave me access to System/Library where I planned to create an Internet Plug-Ins folder and then copy the Plug-In to it. The problem is, I get a permssions error when trying to copy anything from my desktop to the level of the Apple TV. Seems I need root access so, my questions are:

  1. The easiest way would be if I could run the sling player installer mpkg from the Apple TV so everything goes where it needs to. However, I copied it to the Applications folder, went to NitoTV to run it, but nothing happenned. So I guess this can’t be done. Can it?

  2. Otherwise, I need a way to install this Plug-In maybe needing root access to copy the necessary files to the correct locations. Any thoughts?

any progress?  Was looking to do the same with my ATV1, but wanted to hear back from more experiments.