Show the audio format in the list of audio tracks.

Again, I am very disappointed that this hasn’t been fixed in v6!! Is it really so hard to analyse the videos metadata, extract the kind of audio each track has and make it readable? MediaInfo does it, the info can be extracted from ffmpeg. Last night I wanted to change audio on a movie, and there was a rotating string never ending, with the info about the audio codec (and language) just at the end.

Not to mention that even in the movie page the audio description is cryptic. What does it mean “MPEG-4 ALS 7.1” (although I suspect this is a bug)?

See attached screenshots.

Have you updated Infuse to 6.0.1 or higher? There was a fix for mislabeled codec in 6.0.1.

Yup, Infuse 6.0.2 here and I am still getting “MPEG-4 ALS 7.1” in the movie page. Nothing changed in the Audio menu either.

Infuse should have cleared out any invalid tags.

Can you try hitting the ‘Edit’ option and reselecting the correct title to see if that clears things up?

Ok, it worked for the main page! I have got TrueHD 7.1. It still shows the long name in the audio track list in the Audio menu, though. Which is my main concern. Is it working as design or still a glitch?

PS: Since I still had plenty of movies showing ALS 7.1 I have just deleted the whole metadata, now. Hopefully the iCloud synching will make the metadata rebuild a breeze? Not sure how it works.

The text shown in the track list is the ‘Title’ tag taken from inside your videos.

Generally this is something useful like: Surround 5.1 or Stereo - but it looks like this particular file has the file name listed, which is odd. If you like, you can run one of your videos through MediaInfo to see what it says. A screenshot with an example is attached.

We have a few ideas for cleaning this up, but those changes did not make it into 6.0.

Ok, so two things:

  1. Rebuilding (after deleting) all metadata didn’t clear the audio tags for some movies. I have noticed that if I click in a movie and then go through the list on the bottom, if I get a spinning gear then it shows the right audio codec (usually TrueHD 7.1), other wise if it shows immediately all info on the top, I still get MPEG-4 ALS 7.1. I have to manually edit the metadata (as you suggested) and click the correct movie name

  2. This is what I get from MediaInfo, using as source the original movie of this thread:

Audio #1
ID : 2
Format : MLP FBA 16-ch
Format/Info : Meridian Lossless Packing FBA with 16-channel presentation
Commercial name : Dolby TrueHD with Dolby Atmos
Codec ID : A_TRUEHD
Duration : 1 h 52 min
Bit rate mode : Variable
Bit rate : 3 212 kb/s
Maximum bit rate : 5 394 kb/s
Channel(s) : 8 channels
Channel layout : L R C LFE Ls Rs Lb Rb
Sampling rate : 48.0 kHz
Frame rate : 1 200.000 FPS (40 SPF)
Compression mode : Lossless
Delay relative to video : 8 ms
Stream size : 2.52 GiB (17%)
Title : Venom.2018.2160p.BluRay.x265.10bit.HDR.DTS-HD.MA.TrueHD.7.1.Atmos
Language : English
Default : Yes
Forced : No
Number of dynamic objects : 11
Bed channel count : 1 channel
Bed channel configuration : LFE

Since in the audio menu I get this format "[Title] (TrueHD, [Language]) where [Title] and [Language] are like the ones above, I suppose that you could just ignore [Title]?

Sorry James, but this isn’t solved. Even after rebuilding the meta data I have plenty of movies showing the wrong audio tags, ALS 7.1.

I’m not sure but I think some that I manually modified are back to the wrong tags.

Then there is the issue with the names in the audio menu.

Do the incorrect specs get corrected if you use the edit option to refresh?

Are you using Plex or a non-Plex share?

Also, there’s an open thread in the suggestions area for updating the display of audio tracks in the playback menu, and it’s something we hope to get to soon.

  1. I have tried to change manually few of them now (again), and they go back to TrueHD 5.1 - At this point I am afraid that clearing the metadata messed them up again, because I changed quite a few after your initial suggestion.

  2. No Plex shares at all. It’d ruin the purposes of having a NAS, since I’d still need my MacBook always alive (and at home). Just regular SMB v3.

Also, there’s an open thread in the suggestions area for updating the display of audio tracks in the playback menu, and it’s something we hope to get to soon.

Improve audio/subs list UI

Ok, I’ll check that one as well, then. Thanks.

Ok, I see now that the same issue is present even in TV Shows with DD+/EARC 5.1 audio. I tried to modify the metadata of the first episode and it has got the right audio tag, but that worked ONLY for THAT episode. There is no way I’ll modify manually all of them, they are too many.

Hi James,

yesterday I decided to try cleaning out the whole metadata again. There are a couple of scenarios:

iCloud sync ON:

  • I deleted the metadata
  • The metadata seemed to get restored as it was. With the wrong audio tags(like “MPEG-4 ALS 7.1”).

So I tried

iCloud sync OFF:

  • I deleted the metadata again (I did it while the previous was still building the previous metadata)
  • The metadata seemed to rebuild (very slowly) correctly, this time with the right audio tags
  • At the end of the metadata rebuild I had not any movie section duplicated in Italian (which should mean at least the movies had the right audio tag)
  • I checked some of the movies that had the wrong audio tag and they were finally showing TrueHD 7.1
  • I refreshed the metadata in Infuse in both my iPhone and iPad, that have iCloud sync enabled

Today I opened Infuse and there was still a movie with “MPEG-4 ALS 7.1”. Creating a couple of duplicated genre sections in Italian (see post: Bug: Some Movie Categories get split, in both English and Italian)…

Then I checked a TV Show that had the wrong audio tags, and the first episode had the episode description in Italian. The audio tag was “RealAudio SIPR 5.1”. Refreshing manually the metadata for the first episode the description changed to English and the audio tag to “Dolby Digital Plus”. All other episodes show “RealAudio SIPR 5.1” but the description is already in English.

Frankly it’s quite a mess.