Sharing files on external HDD connected to Time Capsule USB port

I’ve just installed Infuse Pro on my new Apple TV4.

I click on “+ Add” folders from my network share, and my Apple Airport Time Capsule appears in the list beneath “available shares”.

What I can’t seem to figure out is how to link Infuse to my 3TB Western Digital external HDD that is plugged into the time capsule’s USB port. I’ve tried configuring all sorts of options within Infuse but nothing seems to work.

I am able to access my Western Digital drive over my network from my MacBook Pro and I’m able to play MKV files using VLC without any problems.

The WD HDD is formatted as Mac OS Extended.

I’ve tried searching the forums for similar posts, but so far no luck.

Any help would be much appreciated.

Hi Ian_B,

I have a similar setup where ideally I’d like to move media I want to watch to the USB drive attached to my Airport Extreme so I can turn my Mac off.

Don’t know if you’ve already figured this out or not but I’ve managed to get it working using the instructions below. I’m not sure if this MAY CAUSE ISSUES with people doing Time Machine backups to their Airport Time Capsule or Airport Extreme as I don’t use this feature. If you have found a simpler way of implementing this I’d love to know!

The only way I could get it work was by doing the following:
-Open the AirPort Utility app (in Applications > Utilities)
-Select your AirPort device
-Click ‘Edit’
-Select the ‘Disks’ tab
-Make sure ‘Enable File Sharing’ is ticked
-Under ‘Secure Shared Disks’ select ‘With accounts’
-Press the ‘+’ sign and enter any username and password (I used ‘media’ for both my username and password)
-Make sure under ‘File Sharing Access’ that ‘Read and write’ is selected
-Click ‘Save’
-Click ‘Update’ to restart your AirPort router

Now to add files on your Mac:
-Open ‘Finder’
-From the top menu bar select ‘Go > Network’
-Select/connect to your Airport device
-Enter the username and password you set in AirPort Utility
-Drag and drop your media files to either of the folders (both are accessible in Infuse)

In Infuse on your Apple TV:
-Click ‘+ Add’
-Select your Airport device from ‘Available Shares’
-Enter the same username and password you set in AirPort Utility previously and save
-Click ‘+ Add Favourite(s)’
-You should see 2 folders here. You can add either or both to your Favorites by holding down the touch surface on your Apple TV remote

It’s not as convenient as I’d like it to be as it means other devices on my network now need to enter a password to move files to the drive and I need to add a username and password in the Infuse app on my Apple TV but it does the job.

1 Like

Thanks epsilon42.

I was able to get things working. Unfortunately, I am now experiencing both the stuttering video as well as the occasional grey screen video freeze while audio continues playing issues. I believe Infuse is aware of these problems and has promised an update to help address them.

I used the same settings as you, however “secure shared disks” is set to “device password” which I believe is the default. I did not need to change it to “with accounts”. I also have “remember this password in my keychain” checked. Time Machine functionality is not affected.

The only change I made to the stock settings was under the “base station” tab where I activated the “back to my mac” function. I was prompted to add my Apple ID and password.

I made these changes, but I was still getting an error message in Infuse that claimed that the time capsule folder was “empty – nothing to see here”. I then realized that my external USB drive was not spinning and was still in sleep mode. I accessed the USB drive using the connect to network feature on my MacBook in order to spin it up. I tried connecting to it again through the Infuse app while the USB drive was spinning and thankfully it recognized the media in the main folder and I was able to add it as a favorite.

In conclusion, I’m not sure if the solution was to activate the “back to my mac” function in the airport utility, which was the only change I made, or if all I ever needed to do was to make sure the USB drive was actively spinning before I tried to link to it using Infuse. I suspect the latter.

I noticed some stuttering video as well but I think it may be related to how the video was encoded. I can view a 3.7gb 1-hour long TV show that will work fine, but then when viewing a 700mb 90-minute movie it will stutter. Had a couple of instances of frozen video while the audio still plays but have only noticed this when I’m fast forwarding or rewinding and it seems to fix itself if I fast forward/rewind again.

With regards to the AirPort USB drive setup. I’ve got it working by using Secure Shared Disks in AirPort Utility set to ‘With device password’ as you suggested. On my ATV in Infuse, when setting up or editing a share I’ve used a random username (I used ‘appletv’), and in the password field I typed in the general password used to access my Wi-Fi and everything seems to be working as I want it. Other Macs on the network can drag and drop to the USB drive connected to my AirPort Extreme and it will appear on Infuse. Note: I tried using the username ‘guest’ as someone suggested this in another thread but it would just display an empty folder. Also, I didn’t have to turn on Back to My Mac at any point.

Hope this helps someone!

Hello,

my setup is similair to Ian_Bs. But i’m using the airport extreme.

Randomly my shared folders disappear from the Apple-TV. That means not only from Infuse but also from MrMC and a file browser.
I don’t think, that it’s a problem of a sleeping HDD, because ist happens not every day. Sometimes it disconnect after a view minutes again or while watching a film.

Are there anyone with a new idea to solve this problem?

Hello - I had similar issues where it would show an empty folder, even though it wasn’t empty. I too set the access to Device Password and I was able to get it working. HOWEVER, I found that I have to have my Macbook open in order for Infuse on my ATV4 to play the files on my external WD HD (which is connected via my Airport Extreme). Please correct me if I’m wrong, but I thought Infuse was supposed to be able to play files off of a HD on an ATV4 WITHOUT having to have a laptop/computer involved?

My thoughts - Infuse is using my Macbook as a server and therefore needs it to be awake
OR
The HD stops spinning and goes to sleep because the Macbook isn’t accessing it with the lid closed. So the HD doesn’t recognize that the ATV4/Infuse is accessing the files and goes to sleep. This causes the file I was watching to stop.

Can someone please help shed some light on this? Should I be expected to have my laptop open when using Infuse on my ATV4, or is there something wrong with Infuse or the HD sleeping that I need to fix?

I just setup a friends DDWRT flashed router with an external hard drive attached and sharing via SMB. It was incredibly easy, infuse spins it up and everything works just like it does on my NAS.

Seems that infuse may be missing some apple specific protocol to get the airport to work.

Hello VanCity! I just purchased an ATV 4K last night and I have a 3Tb TC. My settings are:

For TC

  1. open airport utility on your mac, click on your TC and click edit
  2. take note of your base station name because we need that later to setup infuse, you should also know the password of your TC
  3. click disks, in partitions, the enable file sharing should be checked
  4. secure shared disks option should be “with device password” and remember this password in my keychain should be checked

For Infuse

  1. choose settings, then shares, and choose the name of your TC
  2. in the username field, write the name of your TC and the password should be your TC’s password
  3. you should see new the files or folders in your TC and you can add them to your favorites

(i don’t know if you have resolved this issue a year ago, if not, hope this helps)