Shares not connecting anymore

I’m getting the error: “Infuse encountered an error while trying to connect” on my iOS devices - iPad (15.1), Apple TV (15.1.1) and iPhone 13 (15.1). Still, it’s working fine for me when using the Infuse 7 app (Version 7.2.1) on both my Macs (one with Big Sur 11.6 and the other one with Monterey 12.1 beta). Also, using the latest app version on both iPad and Apple TV. Problem is really concentrated on the iOS devices… And maybe a recent update (on either Infuse or iOS), as everything was working fine til last weekend with the same setup (I have a Google WiFi mesh network and I’m getting shares from Time Capsule and a Synology DS220j.
Spend the last 4h trying everything… Looking forward to help finding the issue.

Edit: just sent the Diagnostics SV08J from my iPhone.

I’m having this issue on my Apple TV 4k streaming from a share on my local iMac running Big Sure 11.6. I can only fix it be forgetting and re-adding the share, but the issue will eventually happen again.

Going on an assumption here… Go to preferences on your iMac and then sharing. Near the top it says Computers on your local network can access your computer at:
mine for example says The-iMac-3.local

When you can’t get at the share via Infuse take a look at how the share was created, does it show the same local name or is it different? If different most likely a number has been added. This is a known issue on Macs that have both ethernet & wifi connections active. The solution is to first make sure you’ve assigned your iMac a static ip. Then recreate the share on Infuse but use that ip address instead of the local name.

Yeah I have both ethernet and wifi enabled on the iMac, and was adding the share using the computer name Infuse discovers. I suspect this was causing the issue when the computer or router reboots and assigns a new IP via DHCP.

So I’ve setup a static IP for the ethernet interface and we’ll see if the issue recurs or not.

That should be the best option

The issue is not that DHCP assigned a new ip, instead its the internal working of the macOS that incorrectly thinks there are two computers with the same local network name because the iMac has both ethernet & wifi connections with two ip addresses. Obviously a bug Apple has not addressed. Because it thinks so it automatically adjusts the local host name resulting in Infuse no longer pointing to the current host name. Going the static ip approach and setting up the Infuse share pointing to that bypasses the issue.

The other approach would be to eliminate either the ethernet or wifi connection on the iMac. Personally I didn’t want to do that since the apple watch will only unlock the iMac with wifi enabled plus I have multiple needs for a ethernet connection as well. It’s been two weeks since I made the change here and so far no problem.

Thanks, this makes complete sense now. I’ve seen the phenomenon where it appends a number to the computer name. I have wifi on for the same reason–Apple Watch and continuity features.

By entering the MAC address in the advanced settings of the share for either the Ethernet or WiFi which ever you want to use would also most likely solve the issue.

BTW I tried early on, with the share still pointed to the local network name, adding the mac address in the advanced section, but the problem would still occur.

MAC address is only used to allow devices to wake from sleep state using WOL. If you don’t have the right name/IP address having MAC address won’t help.

1 Like