SFTP performance on iOS/tvOS

Hello,

I noticed this problem few months ago with an iOS version of Infuse. if i stream from a sftp server the maximum speed i reach is 5-7Mbit/s. I ended up using IKEv2 VPN instead + webdav(http). But after a recent purchase of ATV4 that doesn’t have a VPN client on it i’m back to sftp solution and again the speed limitation is there that doesn’t allow me to stream a content with a higher bitrate.

Does anybody else have the same problem?

Thank you.

P.S. I get a full speed from the same server using mbp.

Cheers!

Thanks for the report. We’ll take a look and see if we can track down what may be going on.

1 Like

Anything new about that? Seems to be still an issue. SFTP is 1/4 the speed of FTPS.
I try to stream form a remote server:

  • with Filezilla, SFTP and FTPS are the same speed: 50MB/s
  • with Infuse, only SFTP works, speed is 13MB/s
    All tests on the same device.

I am still using WebDav, but this time over https, thanks to let’s encrypt for free certificates.

Same problem here. With cable and some adjustments on provider side we get now 12 MBit/s but this is still to less.:confused:

Could please acknowledge this? Correcting would be awesome too, pleaaaaase?

After the recent update now WebDAV is broken

Same issue - SFTP results in slow speeds/buffering (10Mbit/s) on macOS/iOS. filezilla (macOS) with the same settings maxes out my internet connection (30MByte/s). @james any status update?

EDIT: Tried the same settings on iOS with FE File Explorer and I get around 20-30MByte/s. The issue is definitely an Infuse one.

SFTP performance still at around 10-14Mbit/s, tested with iOS 15.3 and Infuse 7.3.3

Infuse 7.3.8 - still no change. When will this be resolved? Any updates?

I just checked mine for what it’s worth, get about 50Mbps in IOS 15.4.1, Infuse 7.3.9

Hi, I have created this topic more than 5 soon to be 6 years ago. I gave up sftp long time ago in a favor of different solutions, today it is a wireguard + smb, or https over public internet.

@sfatula What is your hardware setup that you’ve managed to reach those speeds?

I’ve been using sftp on TVOS and IOS for as long as it’s been around. My speed is local on the LAN, so not sure what you are asking. You are speaking of WAN access? I don’t use Infuse remotely.

In my case at least, I am talking about remote connections to a server via SFTP. The speeds are between 10-14Mbit/s on Infuse 7.3.9

(For LAN connections I am using SMB, and the speeds here are adequate.)

So, what are your connections on the LAN then? Same machine, local, what test speeds do you get?

I don’t use smb & sftp in Infuse often, but I notice similar issue when I use.
Tested with the same 30GB movie (Infuse iOS 7.3.9 & Mac 7.3.8) to my local Unraid server.
It’s clear as day that it’s not my Network issue. And there’s something special in Infuse smb & sftp stack, While the speed is acceptable on 1Gb Lan, somehow the speed on WIFI is noticeably slower compare to Plex share in Infuse & other App. @james

iphone XS (wifi):
Plex share > iOS infuse: 420Mbps
Smb & sftp > iOS Infuse: 50Mb
sftp > FE file explorer: 280Mb

MacBook Pro 14 (1Gb Lan)
Plex share > Mac infuse: 720Mbps
sftp > Mac Infuse: 270Mbps
smb > Mac Infuse: 350Mbps
sftp > forklift, transmit, FileZilla: 720Mb
smb > finder, forklift: 500Mb

MacBook Pro 14 (wifi)
plex share > infuse: 570Mb
smb > infuse: 110Mb
sftp > infuse: 70Mb
smb & sftp > finder, transmit, forklift: 500Mb

I don’t see anything outside the normal range with those speeds. Remember that infuse speed test is not equivalent to a file transfer and checks the equivalent speed during playback.

In my case, watching any movie results in buffering issues as 14Mbit/s is not enough (SFTP over the Internet).

I was thinking the same, “maybe the smb/sftp speedtest in infuse is actually streaming speed so playback should be fine”,
but then when I try to play a 50GB 90mins movie over sftp, there are noticeable buffer during playback while no issue over plex share in infuse

I also check the real time streaming speed in my Unifi AP dashboard of the 1st min playback of a 50GB 90mins movie to my iPhone XS.

The issue in Infuse Smb&sftp stack is obvious.

infuse sftp: 50-60Mb, constant buffer
infuse smb: 40-60Mb, constant buffer
infuse plex share: 250-300Mb, no buffer
FE file explorer sftp: 160-260Mb, no buffer