Several error issues

I have an Apple tv 2 (black) that had previously been jailbroken and had xbmc on it. I was having issues with subtitles which is really important to me since I'm hard of hearing so I thought I'd give it a go on updating it....I'm afraid this was a bad idea. I have tried each of the steps several times and rebooted my computer several times. I even tried a factory reboot so my apple tv had the latest updates which I'm realizing now was probably also a bad idea. I was able to get the reboot to be successful one time, but since then have tried other things so not sure whats going on with that. Here is what I'm doing and the errors I get along the way.

When I try to install Seas0n pass everything appears to be working great until it stalls at "Restoring in iTunes. Please wait while script is running".

At this point I close it and disconnect. In iTunes press shift + restore and find the file and try to install that way. All looks great until "The Appletv "Apple TV" could not be restored. An unknown error occured (1604).

Now when I plug it into the tv I get an image of a USB plugging into the iTunes logo.

I have since tried another factory restore but get the message Can't connect to apple restore server. Please try again later. (this was happening both last night and this morning)

I have also gotten it to the point where when I plug it into the tv I get the apple image but the screen then goes black (light on box is still on).

Is there any hope for saving my appletv?

Thanks :)

without a saved shsh blob, you might (better to say “have”) have a 5.3 tethered jb. Proceed with the boot tether and hopefully it will work

I should have mentioned that I have already tried the boot tether.  After getting your message I tried it again and still getting that image of the USB plugging into iTunes.  :/

would you remember the ios version prior to updating it?

Yes it was 5.0.2

That image of the USB plugging into iTunes sounds like you’re stuck in a restore loop. Try tinyumbrella to get it out of that loop and see if you can proceed.


Also, 5.0.2 is a notrious pain in the butt. See this thread for some helpful hints:

I have TinyUmbrella downloaded but it is not seeing my Apple TV as connected.  It has two recovery devices listed (and just identified with a string of numbers) but neither shows as being connected.  Also once I’m able to see that it’s connected am I repairing the recovery, exiting recovery or entering recovery?


if you used the apple tv often and had an atv flash on it all of your blobs saved automatically or if you ever clicked into nito tv if you didn’t have an atv flash 5.0.2 saved or what ever apple was signing at the time you click on it. 


so get ifaith and c what blobs saved, you don’t need to go on a tethered verison because you have at least 1 blob saved

Where do I find iFaith?  I can’t seem to find a good link to download it.

Got it…finally.

Ok so I have iFaith and not sure what to do next…really afraid to do the wrong thing.  So I detected previously saved SHSH files and found the location Files are titled



Not sure if I should try to restore using those?  If so which one?

Also in iFaith it is showing available Blobs

5.0.2 (Cydia)

5.0.2 (iFaith)

5.1 (cydia)


So is it those I’m suposed to use?  If so, which one?  

What is the next step?

Thanks :slight_smile:

Good thing there are saved blobs. Proceed with the jb process, right click and choose 5.0.2