Serious bug with partially loaded files

I love the infuse app on my iPhone and iPad and use it a lot for different reasons. infuse on ipad is my go to app for media consumption on the road.

I have recently ran into a serious issue, which may affect others as well. I will start with how I load content because I think it could be part of the issue. I usually connect at home to my server and download the files. If my trip goes long (the travel part where I use it the most), I will connect home through vpn and download more content. This fails a lot, causing the iPad to sleep or the vpn connection to drop. I am not sure if this use case is a concern but it is really tough to download full content with a slow vpn connection.

Today I gave up, after quite a few retries. I decided to download another way and transfer the files through the files app.

I noticed that the infuse file folder claims to be 130GB but actually has less than half in Real files. I tried to find the invisible files in the files app but they are not there. I solved it by moving the content to another folder, uninstalling infuse, reinstalling and returning the files.

I think this might be due to either

  1. Deleted files not actually deleting completely
  2. More likely, partially downloaded files not visible in the file system.

I would love a better remote download solution and also a solution to clearing these invisible files.

Issue was that recently deleted (although it told this to me when I deleted the content) appears to size count against the folder it originally was in and NOT against recently deleted.

Not sure why this feature can’t be turned off…

Apple changed how deleted/recently deleted items are handled and iOS 16 and this can lead to cases where deleted files would disappear but still take up space. This thread has more info and describes a few ways you can adjust how Infuse handles file deletions.