SeasOnPass Not Working? aTV2 will not boot up!

I recently had to re-jailbreak my apple tvs.  They both started to act up and not perform as they used to.  Upon jailbreaking, the apple tv just blinks and occaisonally shows the apple logo as if it’s going to load, but doesn’t.  It just goes back to blinking at me.  I didn’t see anything here in the forum about it.  I am using a 2nd gen apple tv and I installed all current up to date software, on computer and apple tv, before attempting.  Please help!

Same issue here, bump.

Very vague posts guys!


Would you care to elaborate on when you updated and which firmware your ATV2’s are running? And how you tried to jailbreak if it was before yesterday as no valid jailbreak existed unless you were running it on a Mac.

Sounds to me as though you have not paid any notice to the fact that the lastest jailbreak is TETHERED?

I got it…I just threw the one Apple TV up against the wall as hard as I possibly could while the other one watched. It didn’t want to be next, so it started working. Got one fixed, at the expense of the other :confused:

Can you force a reboot on a thetered JB without breaking the JB?

Latest iOS from latest itunes.

Merely moments before this post - with the latest seas0npass.

Somehow I managed to not only read the documentation, and perform a teathered jailbreak, but I also was inclined to search the forums and bump an existing unique post to gain visibility, hoping someone might actually have some insight rather than stating the obvious.  

Same issue here. I ran SeasonPass today, using the latest version, and the most recent IOS.

It required the tethered boot after SeasOnPass was run. I then installed Firecore successfully.

Now after a couple of reboots, it’s decided that it needs a tethered boot every time that power is lost!


Any ideas?

That is implicit in it being a tethered jailbreak.  It is one of the reasons many prefer not to use tethered jailbreaks

i am having the same problem, my atv2 has been jailbroken for a while and i started to have problems like crashes and glitches so i started fresh.  i have a mac book pro fully updated with itunes fully updated, using the last version of season pass, and the atv2 has the latest os on it, the entire jailbreak (teether) process runs smooth as usual and when its done it says the restore is successful but when i plug it up to my tv all i get it endless led flashing and the occasional apple logo on the screen otherwise the screen is black. Also i have tried starting fresh by restoring in iTunes and rejailbreaking it but nothing works, if i restore in itunes and dont jailbreak, it works fine but no season pass or xbmc. this sucks, i should have dealt with the crashes and glitches

It is not clear from your description whether you kept the power plugged in after doing the tethered boot at the end of the jailbreak process. Your description sounds like the ATV is waiting for a tethered boot to be carried out.


I decided that I would update my ATV2 today from 5.0.1 to 5.2.1 and this quoted comment above describes exactly what is happing to my ATV2.  Jailbreak installs smoothly and everything completes, once I plug into my tv it just keeps cycling with a blinking light and an apple logo is visible for a few seconds every few minutes.  I have run the jailbreak 4 times already too.  I dont have the power plug connected during the jailbreak because I have never had to have it plugged-in in past jailbreaks and the instructions didn’t call for it.  Im regretting updating.




UDATE:  I was able to get it to boot up but only after taking my laptop to the connected ATV2 (Power connected), unhooking the HDMI and plugging in the micro USB and running a tethered boot again.  It started up fine after that.  I then tested if the jailbreak would hold and unplugged the power.  I plugged it back in and now im back at square one.  I have to keep booting it with my laptop!!!  This sux!!!  Is there an UNTETHERED JB for this?

Can you please explain what steps you took to correctly get it to boot tethered?  I’ve watched videos and followed the steps on the guides, however…NONE of these are working correctly to allow my ATV 2 to boot tethered.  The Jailbreak worked fine…or so it seems…but the tethered boot process is not.

Steps I’ve taken:
Jailbreak ATV 2 (ignore the 1604 error provided by iTunes)
Unplug ATV 2
Click “Boot Tethered”
Once prompted to connect and set into DFU Mode I connect the USB cable and wait for the faster flashing,
next I connect the Power cable (Note: flashing doubles in speed now?)
Next I hold Menu and Play/Pause for seven seconds
Seas0nPass finds DFU unit and begins the process…  (Half the time is says it can’t find the DFU device while the other half it gives me the message it’s ready to disconnect the USB cable and connect the HDMI)
I remove the USB and connect the HDMI, but the screen only shows the USB cable -> iTunes screen.

Any help you guys can provide would be really appreciated.  It’s not that I’m not looking on my own.  I’ve reviewed half a dozen video tutorials and searched several forumns…I’m not having the success you guys seem to be having with the tethered boot process…I’m getting mostly FireCore crashes, and when it’s not crashing, I’m getting false positives.

No there is no untethered jailbreak of the latest (5.2.1) firmware. There is no guarantee that one will ever be produced.



That 1604 error might be the problem.  I think thats a USB port error.


Try rerunning the JB but leave the ATV2 connected to the computer and run the tethered boot right after the JB.  (I never unplugged mine but I found the difference was having the power plugged in during the tether boot.)  If that doesnt work try doing everything again with the power cord also connected.

I had the same problem, I just held the 2 buttons like I would on a Tethered boot then pluged in the mini usb and ran the Teatherd boot, and It worked fine.