Seasonpass not running. Please help

I’m having a problem with Seasonpass. it just won’t start. I run Windows7-Ultimate 64BIT. I tried all the different settings in ADMIN mode and still will not run… Please help. I also already made a support ticket without a reply… It has worked previously about 6 month ago and had the same problem only this time it does not seem to work. 

alot of people have this issue and this would be the 3rd post that when clicking the create it just exits out.

it happens on any pc running xp or win7

wish someone would fix the code for us windows users.

i deleted my old ver so now I just have to wait until the new seasonpass can unlock the appletv 4.4.4

but it has to at least work when clicking create software!!! lol

it seems that all the older versions of the create software start to build except the 4.4.4

right click the create icon then you get a menu…

but the 4.4.4 exits.

FIXED… the current ver from the site is no good for 4.4.4

the ver I used of season pass is

anything newer after Jan 2012 download wont work. so I feel sorry for the new people on this project because I got lucky that I save all my downloads and did a restore from my file server from jan… and it worked!


I just got my apple TV today. I am very new at this. I downloaded the most recent seas0npass but it will not start for me. I installed/re-install .net framework several times. I opened it in admin mode with windows xp compatability. I closed all my firewall/virus protection. It still will not work. No screen will pop up for me when i click on Seas0npass. I’m at a lost as to what to do now. I would appreciate any help as to what to do next. Thank you!


btw, im running Windows7 - Ultimate x64.