Seasonpass failing

Seasonpass newest version, downloaded to my Imac running Lion 10.7.5 is giving me a patching failed with reason messasge  after trying to create a new IPSW for the 5.3.

I am using the right click method with season pass and it shows the 5.3 being there. Is it working with Mavericks? I am getting ready to upgrade.

I read somewhere that you could do a Itunes to 6.02 upgrade first and then use season pass to downgrade to 5.3. Not so sure about that one. Any suggestions if I want to wait on Mavericks?

 

There is a sticky that mentions the fact that the latest SeasomPass has problems running on 10.7…5

Thank you. Did see that. Was hoping for an update.