Seasonpass Bricked my ATV!

I followed the procedures to the letter, now it will not get passed the Apple Logo.

Hi

 

I had the same problem, try "Boot Tethered" with Seas0nPass and then DONĀ“T DISCONNECT the Power Plug

Only disconnect the MicroUSB Cable and connect the HDMI Cable

 

 

Just did that.  Black screen.

Now did a Menu + Play button and got back to apple...but sitting there no change.

 

Damn time to get out the extension cord and see if this works....same problems all around. Apple logo, blank, blinky light....nothing.

Just restored my ATV with iTunes, it's working and back to factory default.  I'll try this one more time.  There is some confusion about the powercord.  The Software does not say anything about connecting it but the instructions on the sight does.  Which is it?

Hop Crap it worked...yea you can't lose power.

Nope, bricked again!  Not sure if I'm doing something wrong.  I'm recovering with iTunes again and I'll do some more waiting until this get ironed out.  

Got it to work by pluging the power cable when iTunes finished and then proceeded to Boot Tether.

ATV powered up and is connected to WIFI.... so far so good.

It does not work.  I followed the instructions to the letter and I could not get it to work.  I finally had the power cord on and got it to go to iTunes.  Got an error code as it was restoring in iTunes and not iTunes will not recognize it.  Help.  It just should not be this difficult.  

Yes, rixvette -- I'm with you!  It shouldn't be this difficult, especially after FireCore aTV sells itself as easy to install, no USB thumb drives, free beer for everyone, etc.

I have wasted 13 hours, on and off, trying to get this thing to work.

Now I want my money back! :(

Great Job on the quick fix FireCore and Seas0nPass!!! Works great! It's a BETA people there will be problems.

Absolutely agreed ... and the pictures on the different steps make it really easy to identify when USB and when Power has to be attached.

Timing is crucial aswell, so please really unplugg USB shortly before trying to boot tethered and watch the type of blinking of the Device.

 

Additionally, fireCore even mentions "Seas0nPass makes this as easy as possible, but please do not proceed unless you are comfortable with this process."


If your apple TV just gives you a black screen after tethered boot, just try running the aTV installer again while the screen is blank, this did it for me!

This trick just worked for me as well. Thanks Firecore!!!!