Seas0pass for MAC Jailbreak on ATV 2G - Not verifying July 2015

I’m a regular of jailbreaking ATV 2’s and I’ve been using Seas0npass for months.
All off a sudden on Sunday (5th July) the Seas0pass jailbreak stopped working correctly. I can go through the whole process; Apple TV is in DFU mode and all is going well but at the verifying stage at the end the process is taking a little bit longer to complete and then eventually says ‘Firmware Restore Successful’.
When connected to the power and HDMI I find that it has actually NOT BEEN SO SUCCESSFUL as I just get the Apple logo on the TV saying connect to iTunes.
Why all of a sudden does it appear that Apple is no longer allowing the verification of iOS 5.3 for the ATV 2?
Is it something wrong with my own computer or is the a worldwide thing since Sat 4th/Sun 5th July? I’m starting to think they’ve figured out a way to block seas0npass from verifying new jailbreaks. OH, and btw I have now tried this on 3 separate ATV 2’s all with the same result and re-downloaded the newest seas0npass just in case an update had been pushed out that i missed.
Any help is appreciated.

I downloaded the latest seas0npass for windows. The process worked as normal so I happily now have 4 jailbroken ATV 2’s
Still, if anyone can update on why seas0pass for mac is not completing the verification part of the jailbreak at this time it would be much appreciated!

I have exactly the same issue but unfortunately do not have access to a Windows PC / laptop. Any help appreciated.

I will try and borrow a PC tomorrow.
Very disappointing.

Seas0npass works fine on mac.

Learn how to use DFU properly if you don’t already:

Do not skip step 6! By skipping it you are not finishing the JB!