Seas0nPass & IPSW Unzipping Problems

If Seas0nPass seems to take forever to unzip the AppleTV IPSW, you are probably experiencing some residual effects of the server downtime from earlier this week.

In a nutshell, Apple was experiencing some download server issues starting Saturday of last week which ultimately resulted in many users getting incomplete IPSW file downloads. Since only part of the IPSW file is getting downloaded, Seas0nPass is unable extract the contents of this file.

For the most part these issues seem to be resolved, but if you’re still having trouble please try the steps below to get back on track.

  1. Remove the 'Tether' folder (Mac) or 'Seas0nPass' folder (PC) found in the Documents folder. (Doing this will remove the saved firmware present on your computer).
  2. Re-run the latest version of Seas0nPass to redownload the AppleTV IPSW file.

The correct size of the IPSW download (AppleTV2,1_4.3_8F305_Restore.ipsw) is 334,235,633 bytes.

Direct download link -,1_4.3_8F305_Restore.ipsw


I did that already because that reply was at the end of one of the forums. I went to the Documents folder and deleted the SeasOnPass folder. Before deleting I checked the file size in the “download” subfolder. The filename is AppleTV2,1_4.3_8F305_Restore.ipsw and its size is 296,421 KB. Redownloaded and still freezing at UNZIPPING. I tried to unzip the IPSW file with winRAR and it said “unexpected end of archive” but the filename is as expected: 038-0955-007.dmg. Another strange thing: if I double click on the IPSW file, Itune pops up! Anyway, I’ve tried your suggestion on Windows XP too with same results. Either something’s happening at the Apple Server end or the aTV Flash software is not getting the right signal for End-Of-File. This is all fun and games but I really want to jailbreak this black Apple TV. You must have a Windows machine to test our problems? Thanks.


Hi - I also used your direct download link in your sticky. It downloaded alright but filesize is still 289 MB (296,421 KB). According to your note, this is the truncated file. Still will not unzip.

Unfortunately if you’re still getting the smaller file size the Apple server in your area is still experiencing trouble.

Nothing to do but wait it out I’m afraid.  :frowning:

Worked for me but downloaded firmware from another source



Thanks for the update!

I’ve had exactly the same problem. I’ve tried it on 3 computers, 2 x windows 7 & 1 x windows XP and it gets stuck on the unzipping stage. Is there any way to bypass the unzipping stage or to manually do that part?


I have the same problem, my file have 122,1 MB!!!


i tried to use the firmware AppleTV2,1_4.3_8F202_Restore, seass0npass makes me the IPSW whitout problems but gived me an error when restore in iTunes.


i don’t know if i do all the steps right, or it’s impossible to do with this version?


Somebody found a place when is possible to download the right version AppleTV2,1_4.3_8F305? 




Hi there

I uploaded the correct and working 8F305 build here: [link removed]

I can confirm that you can JB your ATV with this version of the build an Seas0nPass. Just jailbroke both my ATVs a few hrs ago :wink:

Here’s how:

  1. Download the 8F305 build from above
  2. Disconnect ATV from everything and close iTunes
  3. Open Seas0nPass an SHIFT + Click on "Create IPSW" (Win) or ALT + Click on "Create IPSW" (Mac)
  4. Let Seas0nPass create the custom IPSW
  5. Set the ATV into DFU mode when Seas0nPass is telling you to and follow the further instructions

Hope this helps :slight_smile:



Thanks a lot!!!


I achieve download the firmware and all is ok till i must to enter at DFU. I test several times but is impossible!!! i’m still trying

Hmm… This shouldn’t be too hard.

Remove all cables from the ATV and quit iTunes.
Start iTunes and connect only the micro USB cable to your ATV. You’ll see the ATV popping up in iTunes.
Now just hold PLAY and MENU buttons together for about 7 sec (I’m just waiting and looking for an irregularity in the flashing LED on the ATV).
The ATV should vanish from iTunes for a few seconds. When it’s back it should be in DFU.

Good luck :wink:

i have it!!!


I had to connect the power cable to put the atv at DFU, making the other way, 6 sec down menu and 6 seconds menu and play


After, and remaining the power cable connect i had to restore since itunes (had a problem directly from seass0npass) Restore it, but ar the last moment try to restore again(???) and give me an error. But i  went to the TV and upala!!! works!!!


Thanks a lot for your help

awesome! Thanks for all the help :smiley:

Glad to hear that :slight_smile:

You’re most welcome ^^


I wanna do the Jailbreak as I read in this. It’s unzipping and in the DFU Mode the Seas0nPass will write the File to my Apple TV box. But after this, Itunes popped up and I get the Information from Seas0nPass: “ITunes restore script failed!, selecting IPSW in Finder…”

What have I do wrong?

When I disconnected the TV Box and connected with my TV, the Menu is also as it where unjailbroken.

I hope you can help me :slight_smile:


Thank you

HI Webi


You must to open iTunes and pulse restore (with the alt key pressed) Then you must to chose the firmware created by seass0npass on FInder (in the name you see SP)



Hi - Thought I’ll let you guys know where things stand with my SeasOnPass problems. The moderator was correct in that the Apple server was serving up truncated files. My unzip program confirmed that. So, I tried to find a server link for a file of the size 334,235,633 bytes (or close). Go to the iClarified site and picked on the 8F305 file (its the latest). I was able to download acomplete file from that link. I’m presuming its an Apple server. But then I didn’t know how I was going to get SeasOnPass to use it!! Eventually I copied it into the directory used by SeasOnPass (%userprofile%Documents\SeasonPass\downloads). When I fired up SeasonPass after doing this, it recognised the file was there and skipped the download stage and went straight on to unzipping it. The unzip worked and SeasonPass went on to build the files and directories for Itine to use to restore. Excellent! Next thing, I had to plug my aTV2 (black) into my PC with the micro USB cable. I got the cable I use with my Seagate GoFlex external drive. This cable should be complete since external drives need both power and data wires connected. Now we get into the next phase of my problem. Whatever I do, I cannot see the little white light on the front of the box. NO WAY! Tried evrything including standing on my head! If I plug the power cord in, I can see the light - but I see there is a warning (some where in the forums) that you shouldn’t restore with power cord plugged in - or the whole thing might go up in smoke! So I did evrything guys on the forum suggested - including pressing n the menu key and (down arrow) key for 6 or so seconds before doing the menu/pause combination. I just don’t want to BRICK my AppleTV by doing the wrong thing. So, after spending half a day waiting at the UNZIP progress bar, I’m now waiting at the DFU bar (which topic by the way also has a large forum follpwings!).

ok, now itunes want to restore my apple device with the .ipsw file from the finder. Then Itunes tell me, that he wants to do a checkup with apple. During the Checkup, the error message is coming:


“Apple TV can’t restore. This device isn’t eligible for the request build.”


What should I do now…???

Hi - seeing that I complained about the problems with SeasOnPass, I can say now that I’ve jailbroken it!! My problem in gettin aTV2 into DFU was obviously the cable. Looks like the so-called USB “standard” has many versions. The USB micro cable that worked with my Seagate GoFlex ecternal drive didn’t work. So I found another. This was the data-sync cable for my Samsung Focus smartphone. This one worked in that I can now see the flashing dot of light. Even so, please note that some of these cables don’t fit the Apple TV2 USB socket very well. The first time I did it, it started flashing and Windows 7 started installing the drivers and then stopped with message that a cable was unplugged. So, I had to push the cable in a bit harder. It then worked. Same thing happened when, later, I had to rehook it for the restore phase of SeasOnPass. After testing to make sure the USB was working by firing up Itunes and checking to see Apple TV is on the right frame, I unhooked it. Then, fired up SeasOnPass and let it go through the routine (The necessary file with the SP added to the filename is in %userprofile%MyDocuments/SeasonpPass folder). Followed the instruction by rehooking up aTV2 and a minute later, shift-clicked the restore buttton. Everything went as in the instructions. Took it upstairs to the TV. Powered it up and after going through a few steps of initial setup, it was up and running. A new item appears on the menu: SeasonPass. NOW I’M INTO THE aTV FLASH phase. Watchout for the next installment!

Hi guys:  Installation of aTV2 Flash (black) worked with no hitches. It adds an additional item to the menu bar on the TV. Its called maintenance and there you can choose what additional items you want installed - such as nitoTV and XBMC. Now, I’ve just got to figure out how to access those TV episodes on Hulu and the networks. Thanks Firecore and I presume we’ll be notified when the beta version switches to final product. Thanks.

PS. It might be good idea to say on stickie that one should check the light on the front of the aTV since other people, like me, can be using all different kinds of USB cables.