seas0nPass downloading 5.3 restore ipsw on my apple tv 5.2

I’m jailbreaking my apple tv 2 running on 5.2 and when i clicked on create ipsw in seas0npass i see it starts downloading the restore file but it says 5.3. Is that correct or should I stop? I noticed in the how-to video that the file being dowloaded was 5.2 which is why i have this concern.

Thanks,

I tried right clicking creating ipsw to select the 5.2 firmware but it says it is not compatible. I just re-checked the firmware on my apple tv and its 5.2. Anyone have any idea why it would download 5.3 in the create ipsw section? Should I restore my apple tv and re-try?

try to save your shsh blob first before proceeding to jb

i have save my ssh blog. How can i force season pass to use 5.2 and not 5.2.1?

 

thx

I have same problem.I am waiting your answers to see what can i do

If you do not specify an explicit release then SeasonPass will download the latest release it supports (currently 5.3). If you want a different release then Shift-click the Create IPSW button should give you a list of releases to choose from. Note that if this any release other than the latest you must already have save shsh blobs (firmware signatures) for that release on your device or the jailbreak will fail.

YEs I followed the shift click and choose 5.1 which is my firmware and it worked! yahoo!! Yes I did saved my ssh blog using ifaith.

I’ll use this one to replaced my atv2 5.2.1.