SDR washed out in forced 4K HDR mode - Other apps unaffected

I’m having a weird problem I’m hoping someone can weigh in on.

Background:

I have an Apple TV 4K 2021 hooked up through a Denon X3700H receiver to a Sony Z9D TV.

I think Sony implemented Dolby Vision poorly on TVs of that generation, using player-led DV. The TV doesn’t have a Dolby Vision Bright / Dolby Vision Dark profile, just one general DV mode.

The result is that DV content looks extremely dark and almost unwatchable, even in a dark room.

There is no way to disable DV on the TV. Leaving the Apple TV in 4K SDR mode with Match Content - Match Dynamic Range enabled, results in DV content forcing the TV into that dark DV mode. DV is not technically enabled on the Apple TV (I see the option in Settings to enable it), but it seems to pass DV content to the TV regardless, triggering its DV mode.

As such, I leave the Apple TV in 4K HDR mode all the time. The menus look washed out but that doesn’t bother me. Playing DV content in this mode results in the TV going into regular HDR mode. This is the only way I’ve figured out to disable playback of DV content and still get HDR.

The Problem:

When playing SDR content using Infuse with the Apple TV in 4K HDR mode, the image looks very washed out, almost like there’s a 20% opacity white filter over everything. Blacks look grey and blacks and dark areas of the image have blotchy artifacts.

Playing HDR content is fine.

Oddly, playing both SDR and HDR content in Plex or any other app looks fine. So it seems like every other app is able to somehow convert SDR content to display properly with the Apple TV forced to HDR mode.

Is there a way to resolve this or can a fix be implemented so that Infuse works correctly as do other apps?

The Apple TV must detect that a DV TV is connected, even if you have it turned on and turns it back on again. Looks like a firmware update in 2018 or so added Dolby vision. Maybe you can downgrade it??

Also look at your denon. Maybe you can turn if enhanced color setting for the hdmi port. Although that could disable HDR , don’t remember. Someone mentioned if you use the secondary hdmi you might lose Dolby vision (and eARC unfortunately).

Thanks for your suggestions.

Indeed DV was added to the Z9D TV with a firmware update. Had I known how poor the implementation would be I wouldn’t have upgraded. Having said that, the firmware updates also resolved other performance issues. There is no way that I know of to downgrade the firmware, and I don’t even think I’d be able to get the old file.

I tried changing HDMI mode from Enhanced to Standard on both the TV and the Denon without change. Is there another colour setting? I tried changing chroma settings on the Apple TV also without change.

I would like to retain HDR, just lose the DV. Can you elaborate on the secondary HDMI port?

Just as a test, you also may want to try connecting the ATV HDMI directly to the TV instead of going through the AVR first. That will ensure that the AVR isn’t throwing it’s own twist into the formula.

Do you know if the Apple TV’s Chroma (in Settings > Video and Audio) is currently set to 4:2:2? If so, you may try switching this to 4:2:0.

With 4:2:2 HDR enabled, the output will be 12-bit (instead of 10-bit) which has led to some reports of issues in the past with certain TVs.

I run the Apple TV with 4:2:2, but have also tried 4:2:0 without any change to the strange behaviour.

Like I said, this seems to be isolated to Infuse.

This issue is currently under investigation.

Hi @james,

Just wondering if there’s an update on this and perhaps an estimate as to when a fix may be implemented.

Is there an update on this? I’m considering moving back to Plex because this is bugging me so much.

I asked earlier and didn’t hear back. Hoping it’s actioned soon.

So I really wonder when this will get implemented… if I see correctly it’s been over a year since this was reported and still no update regarding progress was made.
I don’t like Plex for many reasons but this ain’t one, SDR movies look perfect on forced HDR.
Infuse looks terrible and not useable.

1 Like

I am running the most current version (I am on subscription), now with tvOS17 even… still, when Apple TV is set to force HDR only (matching disabled) infuse is the only app playing SDR content washed out, with raised shadows or how to call it. But it is basically unusable… so I am forced just for infuse to abandon forced HDR and use content matching

1 Like

I’m really curious. What scenario leads you to want to have those settings?

Weird question, I think the scenario is pretty obvious one → No black screens while switching between content/videos. Simplicity.
Apple forced HDR is actually pretty consistent and accurate in the latest iterations so I don’t see any downside.

Cool. Thanks for stating what’s obvious to you and apologies for asking a simple question.
I guess i must be doing it wrong to not have that issue.

Yes you are probably not able to spot it maybe you are using some automatic TV settings or something that compensate for that. I do use S95B with calibrated firmmaker mode so I spot literally all changes in image brightness.
It is pretty obvious for SDR content that it is washed out in Infuse while using forced HDR.

We have looked into this, and in some cases the Apple TV will add certain post-processing effects if the content type does not match the video output. This does not affect all videos, but can appear in certain cases. The same behavior can be found in a number of other apps as well.

In general, it’s best to keep the Match Content options enabled as this will allow the video output to match the content being played, providing the best possible picture quality.

I understand there are cases where this may not be desirable for various reasons, and there is an approach we have found which could help improve things in this area. However, the changes could have a number of potential side effects, and will require a fair amount of testing before it is made available.

One thing to note is going the other way (EG forcing SDR when playing HDR) does not seem to exhibit this behavior, so if you prefer quick-starting playback then this may be a reasonable option for now.

I’ve got my AppleTV set to 4K Dolby Vision but with Match Range disabled (otherwise when my kids are watching YouTube the TV goes blank for 5 seconds while modes are switched between each and every video).

Just tonight I noticed that when watching an SDR movie in Infuse DV is triggered (which I expect, since the AppleTV will now “convert” everything to DV to avoid matching content) but, it is WAY too bright and the colors are washed out. Is this expected? Watching the same SDR film on Netflix (Match Content still disabled) looks fine.

If I set the AppleTV to 4K SDR or if I set Match Content to ON then everything looks correct (Netflix and Infuse look identical).

I assumed that the AppleTV just told the TV that the stream was DV but of course didn’t have any actual DV metadata to send along with it, so everything remained in SDR. It seems to be working this way for Netflix but not Infuse.

I can take some screenshots or pass along a video clip of that helps!

1 Like

I’ve noticed the same thing.

I typically set my AppleTV to Dolby Vision with match range disabled. SDR content in Infuse has elevated black levels (best way I can describe it). But it seems fine in other apps. It’s mostly noticeable in dark scenes or black screens with logos on it (edges of the logos are too bright).

I know one answer can be “enable frame rate matching!” but there are reasons for having it disabled for some users.

1 Like

Set the Apple TV to SDR (60 Hz) including match range and match frame rate. This way content is being played back as it is supposed to.