Sapphire not updating TV shows again

I have updated to ATV flash 4.1.5 and now when I go to import new TV shows it finds them but does not update them sapphire still imports new episodes for tv shows that were already imported before the update this happens every time I update the ATV flash 4.1.4 etc… also is there a way of saving the metadata from the apple tv in case I will need to factory restore to save me importing over 1TB of movies?

Thanks for your post bomber - I am having the same problem and I thought I must have been doing something wrong. I just installed Sapphire so I don’t have anything added at all yet.

As for saving the metadata, yes, it looks like you can. Make a copy of the folder at “~/Library/Application Support/Sapphire” and you should be good to go. I can’t verify this info but I got it from the Sapphire FAQ: http://appletv.nanopi.net/faq/. Scroll down to the question “I have more than one device running Sapphire do I need to import again?”

Hope this helps and I hope the ATV Flash guys can resolve this! I was really looking forward to this functionality.

Update: To fix the problem just update the Scrapers. It worked for me

See http://forum.atvflash.com/viewtopic.php?f=6&t=3403&p=14330&hilit=sapphire&sid=8608832778be40dea676ff5c4627e4b3#p14330

I tried updating the scrapers and it just sits there spinning does anyone how to fix this?

Is Sapphire currently up to date? (check in Maintenance --> Manage Plugins menu).

Having the same problem, but weirdly it updates some & some not. I had a better quality version of a TV show so I replaced the old ones on ATV with new ones with exactly the same file names but it wont update them even though it recognised the name of the series