Sandisk media drive

Could someone please explain how to access Sandisk media drive from infuse. I waited ages for the update and still can not do it!

Same problem here… The SanDisk Media Drive doesn’t show up in Shares. Any solution for this?

It seems there are 2 separate types of Sandisk Connect drives, and sadly the Media model can not be accessed from within Infuse as it does not support WebDAV streaming.

To access files stored on the Connect Media drive you would first need to use the Connect app to browse the drive, then select Infuse as the player when opening the file.

The Sandisk Connect Flash drive does support WebDAV, and can be accessed/detected from within Infuse.

Sorry for the confusion.

Thanks for the reply but it must be able to work somehow as other apps can access it. It’s playing pro app can access it if you want to see it working!

Hmm, that’s interesting.

We’ll take another look and see what we can do.

That would be awesome! Please keep us updated…

The app “Its Playing Pro” works great for connecting to it… But the interface sucks.

If you open their app, go to network it will find the Sandisk Wireless Media Drive immediately and I can watch the movies stored on it so I know it is possible. I just paid for the Infuse 3 Pro upgrade hoping it would work and it still doesn’t :frowning:

Please look into this again as I know it is possible and I love the Infuse interface.

-Brandon

I confirm that brandont.4172 is correct, I am in the same situation

any news on this?

Hi there,
In the set-up screen, infuse is stated as one of the files that would work with media drive.
This was the prime reason for me to purchase the drive.
As the video software currently attached with the media drive is very poor , (interface), please setup the media drive to use the infuse interface.

BTW, what is the key difference of the media and flash drive. Why two versions?
Thanks
gmshots

I get the feeling that user requests are not really a priority. I keep paying for their upgrades hoping every time it will work only to get a smack on the old credit card.

At this point I think I will sink my hard earned cashola into a product and company that wants to make it work. I even told them 3 months ago about a program in a previous post to look into as it works, I just like the infuse interface better.

Hope they see this and make a note of it. No more paying for upgrades from me until they address this, It isn’t just an issue with me there are several of us here that want this feature to work and I know it is possible if someone wants to devote some programming time to it.

I would understand if indeed it was a user request but this is feature listed in the “Videos on the go” section of the Infuse mais page.

Yup you are right…
“Connect with AirStash®, SanDisk Connect, and other Wi-Fi travel drives to download or stream content from just about anywhere.”

I just Googled “SanDisk Connect” and it shows the SanDisk Connect Wireless Media Drive right on the results as well as pictures. They need to get it working if they are advertising it.

Don’t really understand.
What I have observed is that applications like “it’s playing pro” accesses the SanDisk drive easily while infuse takes ages to lock on and there is stuttering during movie play back.
Infuse needs to address this situation to enhance itself.

Hey guys, found this thread while Googling. I’ve actually been able to connect to the drive and see files but its a bit flakey. Here’s what worked for me:

  1. Connect using the wireless connection from iPad to Connect device
  2. Open Connect app and make sure you can browse files and everything is working
  3. Open Infuse and click the “+” sign on top right corner to add files
  4. use “via network share” option with the following settings:
    • Share Name: (whatever you want)
    • Protocol: FTP
    • Address: 192.168.11.1
    • Username: admin (factory default, if you changed it, you’ll have to change this as well)
    • Password: admin (same as above)

Then click “Save”

This should create a connection that will show up in “saved shares” down below. Test it by clicking the name you gave it (mine is called “Media Drive”. If you have an SD card installed, you should see two folders: “sdcard” and “storage” Clicking either of those should allow you to browse the files. If not, you probably got the wrong username and password. If you can’t remember what they are, do a factory password reset by holding down the power button (when disconnected from USB) for 10 seconds until all lights are blinking, then release. It will reset the username and password to “admin”

Now once you’ve connected, go into the Connect app and turn on the WiFi passthrough (Settings -->Connect to Internet).

This will allow Infuse to scrape the metadata for your movie files.

This works, but its a bit kludgey.

Also, the Connect app has a nasty tendency to “fall asleep” and lose its connection to the Media drive, which will then of course kill your connection from Infuse. You have to periodically go in and give it a kick in the nuts to keep the wifi connection alive.

Thank you bpchristensen
That worked for me, FireCore should pay you.
The only difference is that my app is called Media Drive, not Connect
Thanks again

My bad - you’re right. The app is called “Media Drive”. The device is called a “Sandisk Connect” (that’s what the label on the bottom says)

Thanks for the info bpchristensen!

I had no idea the Media Drive supported FTP - the normal Sandisk Connect drive is WebDAV based, similar to an AirStash.

Hi. It seems that the 3.04 upgrade breaks the FTP access (can login but shows empty folder).
Any suggestion?
Thanks!