Resume not working

I have a problem when trying to resume any of my tv series or movies on my Apple TV 4K.
If I try to resume Infuse asks if I want to resume playback (??.??) I click it and then comes the loading wheel and eventually Infuse says not possible to load.
If I start the movie/series from beginning it works fine.
This is a new problem as it used to work fine.
I am using latest version on tvOS.
Resuming works on my iPad.

Have you tried a restart of the ATV? Sometimes updates have a way of introducing gremlins that a restart will fix.

Also you may want to include the actual version number of both Infuse and of the tvOS since both get updated frequently.

Yes I have restarted a few times.
tvOS ver. 16.1 beta
Infuse latest stable ver. And also tried latest beta ver.

I just tried multiple resumes on multiple TV show episodes and movies and all worked as their supposed to. No hesitation and no errors.

This was with tvOS 16.0 and Infuse 7.4.6

It may be an issue with the tvOS beta.

I don’t know if the devs would check but you may want to send a diagnostics report and post the code here.

Thanks for checking.I have two Apple TV 4K with 16.1 and same problem om both.

Just ran diagnostic, the code is 096y6