restoring in itunes STUCK

Once I pass the dfu mode. I get the message from seasonpass saying restoring in itunes, please wait script is running. itunes opens up but nothing happens and my pc starts getting stuck on itunes.


I have tried different usb ports, different cables an itunes is up to date. I have already used season pass on my pc with no issues.

The same problem here!!


I’m having the same issue as well.  I thought maybe it was iTunes Match that was causing it to get stuck.  Turned it off and it’s still not working.

Same here. Tried my Mac first, then my PC: on the Mac Stuck while restoring. On the PC no jailbroken Apple TV after a normal jailbrake session as it seems onscreen. Script not working on the newest iTunes?

I’m glad I’m not alone

I don’t which of these made the difference, but mine is working and thought I would let you know.  After trying it again, when it got stuck I did option + restore and manually selected the firmware out of the tether folder. (My path is user/documents/tether)

It installed and thought it worked.  So I hooked it up to my tv and set it up to see that it hadn’t been JB.  So I went back and tried it one last time. I ran seas0npass, put in DFU mode, and WAH-LAH, it worked as it should!!  The setup ran flawlessly.  So I’m not sure what did it, but it’s working now.  Hope this helps someone!

I almost wonder if after the initial clean restore, setting it up on your tv first, then running seas0npass made the difference.  I don’t know, but good luck!

I also had to click on shift + restore. Then I was able to pick another version that I had backed up(it was in my season pass folder). You should always back up your atv2, just in case.

My atv2 is still jailbroken, but with version 5.02

I still have to figure out my issue with iTunes jamming up.


It worked just fine for me ! Thanks !

I was having the same exact problem as slicksam6.  I tried it on 2 Macs (my iMac and my MacBook Pro, both running OS X 10.8.2 and iTunes 11.0.1).  Same thing.  Seas0nPass downloads the ipsw file, patches it, and tells me to put it into DFU mode.  When I do, it loads something into the ATV, then says it’s running the iTunes script.  iTunes launches, but does nothing else.  I option-click the Restore button, navigate to my Documents\Tether folder, and select the patched ipsw file.  iTunes appears to upload the stuff to the ATV with no additional errors.  I close iTunes.  Meanwhile, Seas0nPass is still displaying the message saying the iTunes script is running, and I have to cancel it.  I then plug the ATV back into my TV, and the FireCore icon is nowhere to be seen.  No jailbreak.  I tried just about every suggestion here, and nothing worked.


Ultimately, I tried again using a friend’s Windows 7 PC, and everything worked perfectly!  Strange to think this all worked on a Windows PC, but not on a Mac!

I was having all kinds of problems… OS X 10.8.2, iTunes 11… first got new cable and made progress… script went all the way through and then I got some error at the very end after it completed and getting the Ok. Then I kept getting this problem of waiting for the script to finish after iTunes started with nothing seeming to happen. Seas0npass would drain all my available memory down to just a couple of mb’s available sometimes locking up my computer. As soon as I would stop Seas0npass, when I could, all the memory would come back. I saw something that said the correction was to revert your iTunes back to 10.7 from 11 using these instructions at the link below. After doing that I had no problems at all. Seas0son pass completed with no problems, atvflash installed with no problems and everything is working!




Did u firstly closed the file selection window(explorer window/finder window/the window that opens up when you’re going to browse through and choose a file for uploading or opening) and then did option + restore and manually selected the firmware out of the tether folder. (path is user/documents/tether)

I got the jailbreak to work by choosing a custom IPSW rather than the default one as detailed here: