Restored to factory - now unable to jailbreak

 

I've done some stupid things to get where I am now but I thought I'd appeal to the community for any possible suggestions other than waiting for a jailbreak.

 

Starting from the beginning, I had a jailbroken ATV2 running ver 5.x (don't recall the exact version) but running fine nonetheless. One day I was compiling a large channel list in one of the TV addons and my power flickered. The ATV went into a boot loop where I would get the spinner on the screen infinitely. I found a workaround online which, if I held the menu button during the boot loop after a few random tries I could get to the main menu. From there I could launch XBMC, etc & everything would be fine until it randomly rebooted again, was unplugged, etc. At this point I would have to repeat the whole process of holding Menu again, etc. etc. Each time it took longer & more attempts.

 

About 3 days ago I was reconfiguring my home theater & had to unplug it. Again the boot loop. Took forever & when I finally got into the menu screen none of the remote buttons worked. Tried 3-4 times & each time same result: would reach the main screen but couldn't navigate. 

 

I had never had to touch my ATV2 to jailbreak it so I was totally new to blobs, what versions were able to be jailbroken which ones weren't, etc. As a result I had nothing. Someone who claimed online to be able to jailbreak it again for me said he'd take a look. What he returned to me was my ATV2 running the latest (6.2, which apparently was just released a week or so prior!) version with no jailbreak, nothing additional. It's basically like out of the box. So I tried doing some research. I found a thread ( http://forum.firecore.com/topic/10197) which mentioned a downgrade to 4.4.2 tethered that doesn't require the blobs to be saved. Tethered is fine with me, I just want my box back to a state where it can be jailbroken. The problem is the forum offers a link with a pre-signed IPSW file shared on Slingfile and their site is down for maintenance.

So basically as a last-ditch effort before I toss this ATV2 in the trash & go buy a new box I need to know am I totally screwed, if *any* help or suggestions can be offered, or what (if anything) can be done. Thanks for listening to my dilemma. Help is appreciated.

5.3 is a untethered jailbreak and it's available to you now and you don't need saved blobs for it at the moment (it's still being signed). Get seasonpass (http://support.firecore.com/entries/387605) and jailbreak it to that version.

Video tut for 5.3 jailbreak - https://www.youtube.com/watch?v=CToM3c5aBUI&feature=youtu.be

List of jailbreaks - http://forum.firecore.com/topic/3418

 iFaith is a good program to see if you have any of your saved blobs on the web

 

Since apple is still signing firmware version 5.3 you can simply use Seasonpass which will downgrade to 5.3 and jailbreak untethered at the same time. 

 

I was able to get the version downgraded to 4.4.2 which apparently is tethered but still having some issues with it jailbreaking. The ATV indicates that 4.4.2 is installed but still not seeing any jailbroken features. Used Seas0npass to do everything, seemed to go through the steps fine but when I connect to the TV there's no indication (aside from the version indicating 4.4.2 now instead of 6.2) that anything has been modified.

 

Could I download the 5.3 IPSW to my desktop, use seas0npass to upgrade to 5.3 & jailbreak from there possibly?

I was able to get the version downgraded to 4.4.2 which apparently is tethered but still having some issues with it jailbreaking. The ATV indicates that 4.4.2 is installed but still not seeing any jailbroken features. Used Seas0npass to do everything, seemed to go through the steps fine but when I connect to the TV there's no indication (aside from the version indicating 4.4.2 now instead of 6.2) that anything has been modified.

 

Could I download the 5.3 IPSW to my desktop, use seas0npass to upgrade to 5.3 & jailbreak from there possibly?

Indeed 4.4.2 is tethered, its a last option when apple is signing the latest jailbreak i.e. 5.3 as earlier recommended, download the latest Seasonpass and proceed to jailbreak while apple is still signing 5.3

Another update lol. Updated to 5.3, everything restored fine in iTunes, all steps went as they were listed in the instructions. Now when connected to TV I get Apple logo at first then blank (black) screen while the light on the front flashes continuously. 

May i know the sp version youre using please

I've since determined that the issue was caused by cutting the power to the ATV to connect it to the TV because the installed 5.3 jb is apparently tethered. Tried installing XBMC via the NitoTV installer, no XBMC icon shows on my main screen, apparently the ATV has to be rebooted for XBMC to show up. So right now I have 5.3 tethered jailbreak installed. Is there a way to transform that to untethered of the same version?

If youre using the latest seasponpass i.e. 0.9.5 then youll have an unthetered version of 5.3. Otherwise, if you have an atv flash version 2.4 then you can untether your device. I hope this helps.