restore symbol after 5.3 untether update

I was on 5.0.2 and I just updated to 5.3 to get the untether and to save my blobs at that firmware.

when i power on and connect to my tv, i get the itunes restore symbol.

I did the process twice thru seas0npass and the result is the same.

I’m on a mbp with 10.9.1 using 0.9.5 seas0npass. 

My process was:

  1. backup thru maintainace on the old setup i had and verfied it was there.

  2. connected the atv2 to my mbp thru usb and chose 5.3 thru the seas0npass ‘create ipsw’

  3. seas0npass went thru its normal process and the atv2 went into dfu as it should.

4)seas0npass gave me the done screen

  1. connected to power and hdmi and I get the connect to itunes symbol

6)repeated the same process to the same result

Any thoughts. comments or suggestions?

I’ve just tried manually selecting the ipsw in itunes with option/restore in both regular and dfu modes.

with dfu i get error 1600 and in regular I get stuck at ‘preparing apple tv for retore’ for a while and then error 1604

I’ve also now tried downloading a stock 5.3 ipsw and tried to option/restore it through itunes. 

With this method it flip flops between preparing for the restore and verifying with Apple and then i get error 9.

Anyone have any ideas?

Try a different cable or different port.

Just wanted to close out my self-help thread here…

Went through 4 different cables. 1 that has ALWAYS worked for me, 2 brand new ones i unwrapped just to use for this and then a cord i got when i ordered a phone from china. 

The china one worked lol.

Stock restore to 5.3 in iTunes then Seas0npass 5.3 untethered jailbreak.

Seems to be working now.

Namaste