Resource busy with SMB network connection


I’m trying to re-map to a Windows share, after having found it necessary to factory restore my ATV & reinstall ATVFlash.

Initially, I entered the network details, but made a mistake, and so deleted and started over. Now I’ve entered them correctly, but I get a ‘resource busy’ message when trying to connect.

I’ve had this error before (some time ago) and I think I recall having to SSH onto the box to fix it. Something about it ‘remembering’ the previous (incorrect) mapping. Unfortunately, I’ve forgotten the actual procedure (and where I found it!).

If someone could advise I’d be most grateful.

Thanks in advance.

You may try restarting both the computer you wish to access and the AppleTV. This should resolve any issues.

Hi, and thanks for your reply.

Actually, the PC and ATV have been restarted many times since this issue appeared a few weeks ago.

There is a fix for this … I just can’t remember it! All I do remember was SSHing onto the ATV, navigating … somewhere … and deleting … something!

In this particular case, Google is not my friend :roll:

This sounds similar to a problem I had a little while back. I didn’t equate it with the ATV ‘remember’ the incorrect settings but you may have hit the nail on the head.

My solution was to a create an entirely new share on the Mac then setup a new mount on the ATV with one or two sample movies. Once that was all happy I then simply changed the settings of the mount to the original shared folder where my movies live, while keeping the mount name the same.

Hope this helps.


Hi, thanks for posting.

I’m gonna factory reset and install ATV 4.1 tonight, so hopefully that’ll be it sorted.

I’d still liked to have known that command I used previously, so hopefully someone will post at some point.